← Back to team overview

kicad-developers team mailing list archive

Re: Through hole pad colors have changed


Le 17/04/2017 à 09:55, Nick Østergaard a écrit :
> Hello Jean-Pierrie et. al.
> I noticed that the colors for plated through holes have changed
> recently and I found it seems to happen in:
> bf21640ae567b9d4f69171e283b61a234997c9ab
> I wonder why this "default" color change has happened without being
> mentioned on the dev list, or if it is an unintentional change.
> Actually it also happens for NPTH pads, so I guess it is only
> dependent on the copper layers.
> I attached a screenshot for visualization.
> Regards
> Nick

bf21640ae567b9d4f69171e283b61a234997c9ab fix a color issue.
The report is:
"Fix a few issues when changing a color in render, in GAL mode.
Now colors of ratsnest, vias, not plated holes and anchors can be set.
However not plated holes still have a color issue"

I tried to fix the color issue for holes.
However hole color (plated and not plated holes) was sometimes lost ( for instance after switching
from hight contrast mode to normal mode, only in OpenGL), and I did not really solved this issue.

A temporary fix was to always use the background color for plated hole, and accept the color issue
for not plated holes.

The full fix is to be done later (with perhaps a user selectable color for plated holes),
with other fixes in color choice and visibility,
the current choice is no longer suitable for a few items in GAL mode (for instance the through hole
pads) and even in legacy mode (many items in Render panel) due to changes in Pcbnew over the years.

Jean-Pierre CHARRAS

Follow ups