← Back to team overview

kicad-developers team mailing list archive

Re: License CC-BY-SA-4.0 used in KiCad


Am 27.03.19 um 18:09 schrieb Wayne Stambaugh:
> Carsten,
> I'm still getting the following git error when applying patch 1:
> Applying: Adding license information for demo files
> Using index info to reconstruct a base tree...
> error: patch failed: LICENSE.README:15
> error: LICENSE.README: patch does not apply
> error: Did you hand edit your patch?
> It does not apply to blobs recorded in its index.
> Patch failed at 0001 Adding license information for demo files
> hint: Use 'git am --show-current-patch' to see the failed patch
> When you have resolved this problem, run "git am --continue".
> If you prefer to skip this patch, run "git am --skip" instead.
> To restore the original branch and stop patching, run "git am --abort".
> Any ideas?

I first assumed you are on the branch 5.1 and so I tried to apply the
patches and failed, so I tried to find any differences between the two
branches and ... found none.

Going a bit deeper that road I looked at the file LICENSE:README itself,
it has line endings as know from DOS/Windows.

> LICENSE.README: ASCII text, with CRLF line terminators

So I tried 'git am --keep-cr' but this isn't also not working.

If I convert the file into the unix format by dos2unix and commit the
modifications I can apply the the first patch without complains by git.

So I see two options, you ignore the first patch and modify the file by
yourself. The patch is just adding two lines. If you want to safe the
original author you can use the option '--author=' to do so. I do this
quite often.

Or you convert the whole file into the unix line ending format and apply
the patches then on top of that. The converting of the line endings will
mostly destroy the file history, OTOH it's a small file and history is
not really important here.

Carsten Schoenert

Follow ups