← Back to team overview

kicad-developers team mailing list archive

Re: eeschema bom plugins


Le 29/04/2019 à 00:48, Dick Hollenbeck a écrit :
> Folks,
> Today I tried to create a BOM from eeschema using a plugin command line that had been
> working for about 8 years.  I need information on this new interface.  Either it is broken
> or I am missing the intended set of goals and intentions.  So documentation on the latter
> would be nice.  Otherwise I am leaning towards the conclusion that this is fully broken.
> Coming from an older version, I have a file
> 	~/.config/kicad/eeschema
> In there is a keyword "bom_plugins".
> The new parser is not parsing the old string, the symptom of that is that the plugin's
> m_name comes up blank.  Fine, another path forward is to blow away the entire value of
> that bom_plugins keyword and start over.  I tried that, and the user interface is fully
> non-intuitive and I simply could not find my way through that simple dialog.
> So I am stuck.
> Here is my old bom_plugins string, which as I said did not parse, I stepped through it
> with the debugger and the m_name field on the first Grouped_By_Value came up empty,
> because now it thinks the PLUGINs constructor takes a filename.  The user manual is fully
> empty on this new interface.
> Here is the value of the config file, shown on multiple lines, although in the config file
> mentioned above it is on a single line.
> (plugins
>     (plugin Grouped_By_Value
> (cmd "/usr/bin/python  /i/pcbs/bom_scripts/bom_csv_grouped_by_value.py  \\"%I\\"
> \\"%P/B.BOM.csv\\""))
>     (plugin "Debug Plugins" (cmd "/bin/sh -c 'echo \\"%I\\"  \\"%B %O %P\\" >
> /tmp/snag-command-line.txt'"))
>     )
> Would be nice to generate a BOM, could do it for the last 12 years, cannot now.

Hi Dick,

I do not remember when and why the config file has changed, but I do not
have any issue to recreate the command line from the dialog (just tested
on Linux 14.04 and 16.04).
This is fast.

Attached the line in eeschema config file I created by the latest
Eeschema version for sample.

I am guessing the easier way to fix your issue is to delete old plugins
config lines and recreate them.

Jean-Pierre CHARRAS
bom_plugins=(plugins  (plugin "/usr/local/kicad/share/kicad/scripting/plugins/bom_scripts/python/bom_csv_grouped_by_value.py" (cmd "python \\"/usr/local/kicad/share/kicad/scripting/plugins/bom_scripts/python/bom_csv_grouped_by_value.py\\" \\"%I\\" \\"%O.csv\\"")  (opts "nickname=bom_csv_grouped_by_value")))

Follow ups