← Back to team overview

kicad-developers team mailing list archive

Re: Windows builds broken


On 5/1/2019 8:53 AM, John Beard wrote:
> On 01/05/2019 13:36, Wayne Stambaugh wrote:
>> On 5/1/2019 8:27 AM, John Beard wrote:
>>> On 01/05/2019 12:53, Jeff Young wrote:
>>>> Someone on the forums had to turn off the qa tests on Linux to get it
>>>> to build:
>> It fails during linking not compiling.  I also tried clang but I get the
>> same error.  Here is the gcc command that is failing:
> Jeff's forum issue is a compiler failure in qa_kicad2step, not linking
> in qa_sexpr. I don't think it's related to this.
>> cd /E/build/mingw64/kicad/product-debug/qa/libs/sexpr &&
>> /E/msys64/mingw64/bin/g++.exe -Wall  -Wsuggest-override -Werror=vla
>> -fpermissive -g3 -ggdb3 -DDEBUG -Wno-deprecated-declarations
>> -Wl,--whole-archive CMakeFiles/qa_sexpr.dir/objects.a
>> -Wl,--no-whole-archive  -o qa_sexpr.exe
>> -Wl,--major-image-version,0,--minor-image-version,0
>> ../../../libs/sexpr/libsexpr.a
>> ../../unit_test_utils/libunit_test_utils.a -LE:/msys64/mingw64/lib -pipe
>> -Wl,--subsystem,windows -mwindows -lwx_mswu_gl-3.0 -lwx_mswu_aui-3.0
>> -lwx_mswu_adv-3.0 -lwx_mswu_html-3.0 -lwx_mswu_core-3.0
>> -lwx_baseu_net-3.0 -lwx_baseu-3.0 -lwx_baseu_xml-3.0 -lwx_mswu_stc-3.0
>> -lkernel32 -luser32 -lgdi32 -lwinspool -lshell32 -lole32 -loleaut32
>> -luuid -lcomdlg32 -ladvapi32
> Do *any* unit tests build? I don't see "-lboost_unit_test_framework
> -lboost_filesystem -lboost_system" in there, and it should be. Does
> CMake have the right paths? For me, it is like this:
> Boost_UNIT_TEST_FRAMEWORK_LIBRARY_DEBUG:FILEPATH=/usr/lib/libboost_unit_test_framework.so


Looks like msys2 folks decided to use boost's cmake support to build
boost starting with 1.70 instead of the old boost build system.  I
thought this was still experimental but I could be wrong.  None the
less, boost 1.70 is broken on msys2 so I guess I will have to downgrade
and pin boost yet again :(  For everyone out there using msys2, do not
upgrade to boost 1.70.  If you did, downgrade boost to 1.69 and edit
your pacman.conf file to prevent boost from upgrading.

> Sadly Arch hasn't got Boost 1.70 yet, so it's a bit tricky to test.
> Cheers,
> John

Follow ups