kicad-developers team mailing list archive
Mailing list archive
Re: A consistent name for the Aux Origin?
Comments from the peanut gallery:
“Coordinates Origin” sounds clunky and feels redundant. Coordinates are always relative to some origin. I like “Grid Origin” if it’s a choice between the two names. Displayed coordinates and a displayed grid should always agree on (0, 0) IMHO, so there’s no need for two separate origins for those.
Two user-positionable origins are enough. Here’s an idea: One “Design Origin” for the grid (and related cursor, placement, etc coordinates), and one “CAM Origin” (if it needs to be different from the Design Origin) to govern the Gerber output.
> On May 18, 2019, at 6:37 AM, Jeff Young <jeff@xxxxxxxxx> wrote:
> We need fewer origins.
> I like the name Coordinates Origin, but why do we then need a Grid Origin? And why a setting for the displayed coordinates? Shouldn’t that always be the Coordinates Origin?
> Mailing list: https://launchpad.net/~kicad-developers
> Post to : kicad-developers@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~kicad-developers
> More help : https://help.launchpad.net/ListHelp