← Back to team overview

kicad-developers team mailing list archive

Re: Supported Python Versions



I typically use Debian stable (Stretch) as a benchmark for dependency
versions which has version 3.5.3 of Python3.  Seeing that Debian old
stable (Jessie) has Python3 version 3.4.2 and Ubuntu 16.04 (xenial) is
3.5.1, I would think 3.4 would be an acceptable minimum version of
Python 3 to support.  Right now KiCad requires version 3.3 or greater
but I'm fine with bumping it to >=3.4 if it saves us a bunch of
conditional python version code.  There is already enough of that with



On 5/24/19 6:02 AM, Ian McInerney wrote:
> I am in the process of fixing a bug related to the importing of the
> plugins (https://bugs.launchpad.net/kicad/+bug/1828595), and the root
> cause is a change that was made between python 2 and 3 in which module
> contains the reload function.
> Unfortunately it isn't as simple for the python 3 side of things, since
> the reload() function has been moved around in both 3.2 and 3.4, so the
> current solution I have would only support python >3.4 and also python
> 2. This leads to the question, what is the minimum python version that
> kicad requires the user to have installed? Do we need to add in the
> support for versions between 3.0 and 3.4? Doing this seems like it will
> complicate the code, since we will essentially be left with if blocks to
> import/call functions based on every conceivable python version.
> -Ian
> _______________________________________________
> Mailing list: https://launchpad.net/~kicad-developers
> Post to     : kicad-developers@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~kicad-developers
> More help   : https://help.launchpad.net/ListHelp

Follow ups