← Back to team overview

kicad-developers team mailing list archive

Re: New package for macOS 5.1.2 stable including ngspice-30 ?


On 6/10/19 4:01 PM, Carsten Schoenert wrote:
> Hello Wayne,
> Am 10.06.19 um 20:15 schrieb Wayne Stambaugh:
>> We cannot make ngspice 30 the minimum version.  There are far too many
>> linux distros where 30 is not available yet.  Please keep in mind,
>> Debian stable and the latest Ubuntu LTS version are the benchmarks for
>> dependency package versions.  I'm fine with packaging macos and windows
>> with 30.
> current Debian stable (Stretch) has KiCad version 4.0.5+dfsg1-4 in the
> archive and no package libngspice0 at all (not even in non-free) so
> there is nothing to take care on here.
> The current Ubuntu LTS release 18.04 (Bionic Beaver) has KiCad version
> 4.0.7+dfsg1-1ubuntu2 and libngspice0 version 27-1.
> At least the KiCad version is long long outdated. So also not really
> relevant too.
> But all relevant current Debian releases are providing a recent KiCad
> version and also libngspice0 in version 30.2-1 (from unstable to
> stretch-backports). This is also available in all Downstream of Debian
> means also in Ubuntu >= 'Cosmic Cuttlefish' are providing KiCad
> 5.0.0+dfsg1-2, but also libngspice0 in version 27. Updates wont happen.
> But Jean-Samuel Reynaud is providing actual versions of KiCad and also
> the depending libngspice0 package and they even work in the always
> outdated Linux Mint distro. So for me your requirements you like to set
> are fulfilled.
> And normally the application is defining the requirements. Simulations
> seems to be for some users an critical option. So if the maintainers of
> ngspice hardly suggesting to use the most recent version of ngspice in
> recent KiCad version I would strongly consider to increase this build
> dependency.
> In the end it's up to the KiCad maintainers to define the requirements
> for KiCad. It was a long road to get ngspice into Debian main but in the
> end it happened, big thanks to Holger again btw! So Debian has no
> problem to provide KiCad with a depending libngspice0 library >= 30.2.

Is this a problem for any of the other package devs?  If not, I have no
issue with bumping the minimum version to 30.  If this prevents any
other platforms from being built, then it will have to wait.



Follow ups