← Back to team overview

kicad-developers team mailing list archive

Re: Attempting to build kicad-git source on Slackware-current Linux


Thanks for the clarification -- and to all who follow-ed up. That was the information I needed. Now using Phoenix 4.1.1a1/gtk3 (wxWidgets 3.1.5) from git to build both wxPython4 and wxWidgets (wxGTK3+ Slackware package) I was able to build KiCad from git.

Thankfully I don't get the segfaults I had with the previous build (using GTK2+ and Python2).

The one new problem I have is that the accelerated graphics no longer work. Eeschema gives the 'Info' pop-up -- "Could not use OpenGL, falling back to software rendering". The 'see details' twisty just gives "Unknown Error".

I built wxWidgets (wxGTK3+ Slackware package) with configure's '--with-opengl' switch. My hardware has not changed -- a very ordinary graphics adapter (Intel Desktop board on-board graphics).

I built KiCad with 'cmake -DCMAKE_BUILD_TYPE=Debug' so can investigate with gdb if needed.

Could you give me any tips on what might be wrong and where to look?

Thanks again

Tom Crane

On Thu, 8 Oct 2020, Ian McInerney wrote:

The build has failed because it appears that your version of wxPython/Phoenix is using wxWidgets 3.1.5 and you are trying to use wxWidgets 3.1.4 in the main KiCad build. Those two versions must be the same in order for KiCad to build properly (otherwise there
will be issues with linking).
The compiler flag tests have no impact on this, they are in the log just because your GCC version doesn't support them so we aren't enabling them.


On Thu, Oct 8, 2020 at 4:38 PM Tom Crane <TPCkicad@xxxxxxxxxxxxxxxxxxx> wrote:
      I am having no success despite having been able to do this in the past.

      Previously I was able to build for gtk2+ with Python2.  Now trying this fails at runtime with eg. "(eeschema:6730): Gtk-ERROR **: 15:29:43.689: GTK+ 2.x symbols detected.  Using GTK+ 2.x and GTK+ 3 in the same process is not supported".  According
      to https://forum.kicad.info/t/gtk-2-to-3-issues/24856/2 GTK2 isn't able to be used any more.

      Instead (my preference anyway) I am now trying to build against gtk3+ and

      I get this error,

      -- KiCad install dir: </usr/local>
      -- Enabling warning -Wsuggest-override
      -- Enabling warning -Wduplicated-branches
      -- Enabling warning -Wduplicated-cond
      -- Enabling error for -Wvla
      -- Enabling warning -Wimplicit-fallthrough
      -- Enabling error for -Wreturn-type
      -- Enabling warning -Wshadow
      -- Enabling warning -Wsign-compare
      -- Enabling warning -Wmissing-field-initializers
      -- Enabling warning -Wempty-body
      -- Enabling warning -Wreorder
      -- Check for installed GLEW -- found
      -- Check for installed ZLIB -- found
      -- Check for installed Python Interpreter -- found
      -- Python module install path: lib64/python3.8/site-packages
      -- Found Phoenix 4.1.1a1/gtk3 (wxWidgets 3.1.5)
      CMake Error at /usr/share/cmake-3.18/Modules/FindPackageHandleStandardArgs.cmake:165 (message):
         Could NOT find wxWidgets: Found unsuitable version "3.1.4", but required is  at least "3.1.5" (found

      Call Stack (most recent call first):
         CMakeLists.txt:808 (find_package)

      -- Configuring incomplete, errors occurred!
      See also "/tmp/SBo/kicad-git/build/CMakeFiles/CMakeOutput.log".
      See also "/tmp/SBo/kicad-git/build/CMakeFiles/CMakeError.log".

      CMakeError.log shows the test compilations failing with these three errors,
      c++: error: unrecognized command line option '-Winconsistent-missing-override'
      c++: error: unrecognized command line option '-Wmismatched-tags'
      c++: error: unrecognized command line option '-Wimplicit-int-float-conversion'

      BTW I am using GCC 9.3.0.

      I built wxWidgets-3.1.4 using a slightly modified third party SlackBuilds
      script for the wxGTK3 package, which includes the following configure,

      ./configure \
         --prefix=/usr \
         --libdir=/usr/lib${LIBDIRSUFFIX}/gtk3 \
         --mandir=/usr/man \
         --docdir=/usr/doc/$PRGNAM-$VERSION \
         --localstatedir=/var \
         --sysconfdir=/etc \
         --disable-precomp-headers \
         --disable-stl \
         --enable-graphics_ctx \
         --enable-mediactrl \
         --enable-plugins \
         --enable-unicode \
         --with-gtk=3 \
         --with-opengl \
         --program-prefix= \
         --program-suffix= \

      It includes the '--with-opengl' option as required by Kicad at

      Initially I built the SlackBuilds wxPython4 package which uses wxPython /
      Phoenix version 4.0.7.post2 and tried building Kicad with that.

      Then I tried the wxWidgets/Phoenix git source (reports as Merge branch
      'sip-4.19.24').  The Kicad build log above was built against that.

      I am confused as to whether my Kicad build log failed due to compiler flag
      or package dependency problems...

      I also tried building the kicad-5.1.7 stable/release (with gtk2+,
      Python2).  That was successful but my current project's new format files
      (eg. .kicad_sch rather than .sch) means I cannot use kicad-5.1.7.

      My last successful build of kicad-git (i.e. from
      https://github.com/KiCad/kicad-source-mirror.git), used gtk2+ & Python2,
      has nasty bugs -- eg. segfaults when trying to switch between sheets in
      eeschema and is barely usable which is why I need to rebuild.

      I am stuck.  Please help!

      Tom Crane.

      Tom Crane, Digital Electronics Engineer, Dept. Physics, Royal Holloway, University of London, Egham Hill,
      Egham, Surrey, TW20 0EX, England.
      Email:  T.Crane@xxxxxxxxxx

      Mailing list: https://launchpad.net/~kicad-developers
      Post to     : kicad-developers@xxxxxxxxxxxxxxxxxxx
      Unsubscribe : https://launchpad.net/~kicad-developers
      More help   : https://help.launchpad.net/ListHelp

Follow ups