← Back to team overview

kicad-developers team mailing list archive

Re: Python 3 now required


On Fri, Jun 04, 2021 at 02:50:37PM -0400, Kevin Cozens wrote:
> On 2021-06-04 1:34 p.m., Seth Hillbrand wrote:
> > KiCad now officially only supports Python 3.
> [snip]
> > The current minimum Python version is 3.7 (due to a module test call we
> > use) but we are looking at potentially supporting Python 3.6 if we can
> > handle dynamic reloads.
> I have 2.7 and 3.6 installed. The build process only sees the 2.7 version of
> Python and not my 3.6 version of Python.
> If 3.7 is required I won't be able to build it until I can update the
> version of distro I run. Not easy for me to update my distro as someone
> broke the update/upgrade process pretty much requiring a fresh install in
> order.

Same problem here (Ubuntu 20.04-64).

How can I say to the builder to not consider the python 2.7 installed but
only the 3.x version?


Marco Ciampa

Follow ups