kicad-developers team mailing list archive
Mailing list archive
Re: Python 3 now required
Kevin Cozens <kevin@xxxxxxxxx>
Fri, 4 Jun 2021 14:50:37 -0400
Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.10.0
On 2021-06-04 1:34 p.m., Seth Hillbrand wrote:
KiCad now officially only supports Python 3.
The current minimum Python version is 3.7 (due to a module test call we use)
but we are looking at potentially supporting Python 3.6 if we can handle
I have 2.7 and 3.6 installed. The build process only sees the 2.7 version of
Python and not my 3.6 version of Python.
If 3.7 is required I won't be able to build it until I can update the
version of distro I run. Not easy for me to update my distro as someone
broke the update/upgrade process pretty much requiring a fresh install in order.
http://www.ve3syb.ca/ | "Nerds make the shiny things that
https://www.patreon.com/KevinCozens | distract the mouth-breathers, and
| that's why we're powerful"
Owner of Elecraft K2 #2172 |
#include <disclaimer/favourite> | --Chris Hardwick