← Back to team overview

ladon-dev-team team mailing list archive

[Question #232116]: can't use inputs with several lines in SOAP services


New question #232116 on ladon:

Let's say I have a WS such as this: 

@ladonize(unicode, rtype=unicode)
def upload_file(self, contents):
	"""Validate inputs. See documentation at https://wsamiga.fcsc.es:8444""";
	print "received: "+contents
	return contents

When I acess the service, passing something that contains some new lines (\n), they disappear. 

   "This is
   a two lines string"
will result in the WS printing:
    "received: This isa two lines string"

I've also tried with carriage returns instead. And also I've tried to use str instead of unicode and PORTABLE_STRING as well. So far, unsucessfully. 

I'm using Taverna as a client( a GUI for managing workflows  compatible with WSDL services). I was using spyne previously but we wanted to move to ladon. With spyne, this issue didn't happen. (therefore, I don't think it is a matter of the client)

For the record, I'm serving it with uwsgi server.

Any clues to what is happening?

You received this question notification because you are a member of
Ladon Developer, which is an answer contact for ladon.