← Back to team overview

launchpad-dev team mailing list archive

Re: getting the source


On 26/05/15 20:55, anatoly techtonik wrote:
> On Tue, May 26, 2015 at 12:35 PM, William Grant
> <william.grant@xxxxxxxxxxxxx> wrote:
>>>> As I said, it's not ready yet. The page will be revised to use the Git
>>>> repository when Git becomes the primary VCS for Launchpad's code. Nobody
>>>> runs Launchpad from Git yet, so it's untested and we can't recommend it.
>>>> We also can't yet accept merges from Git repositories, so a Git clone is
>>>> only useful for read-only work today.
>>> I can test and send you patch files. It seems easier than grok Launchpad
>>> merge/branch model.
>> There's nothing complicated about submitting patches. Read through
>> http://doc.bazaar.canonical.com/latest/en/mini-tutorial/ to get going
>> with Bazaar, and let us know if you run into any problems with getting
>> it onto Launchpad.
> That's not mini. It takes more than 15 minutes to get through.
> The whole chapter about creating web accounts is long and boring.

Long and boring? It's seven simple one- or two-sentence steps that fit
in half a screen with very generous spacing. Steps 4 and 5 are not
necessary if you're contributing to an existing project.

> The
> name "publishing your branch on launchpad" assumes that reader knows
> about what the "branch" is, but I don't. Is that a Git style branch or HG style
> branch, what is its name if it is my own branch?

It's a Bazaar-style branch, conceptually close to a Git-style branch.
explains the core Bazaar terminology.

The name would usually describe what you were doing in your branch; see
https://code.launchpad.net/launchpad/ for examples.

> Then I am running this from a container, so obviously there are no SSH keys
> for security reasons. The whole "upload keys", "make a team" assumed that
> I have only one PC to work from. That's wrong. It is an unnecessary hassle.
> What I need is a prompt to login or authenticate using a one-time token that
> opens access to commit to repository under my name for a few hours.

Launchpad only accepts pushes using SSH keys, so you need to give Bazaar
an SSH key if you want to push to Launchpad. Random interactive prompts
for authentication are unnecessary hassle.

>>>> The Getting and Running pages could indeed use some work, and you have
>>>> some very good points. But I think it's a better use of time to fix them
>>>> as part of the Git rewrite, rather than making big changes to content
>>>> that's only going to exist for a handful more weeks.
>>> That's cool. How I can be kept notified when that happens?
>> You can subscribe to the wiki pages.
> No. I can't. There is no such option on dev.launchpad.net
> Such option exists on main help site, but it is buggy. I subscribed to the
> wrong page and there is no option to unsubscribe. I also don't see any
> signals that I am subscribed to the page I am currently viewing.

Ah, indeed. Something has clearly broken with the recent upgrade of the
wiki software. I'll try to fix it.

>>> On the other hand, updated documentation would save me some hours,
>>> and fixing should not be more typing that replying to this list for somebody
>>> with wiki edit privileges. Here my three attempts to launch launchpad:
>>> http://piratepad.net/15min-launchpad
>>> http://piratepad.net/15min-launchpad-2
>>> http://piratepad.net/15min-launchpad-3
>> None of those include any details about the errors you encountered. You
>> also seem to be using experimental container technology (LXD), and to
>> never have actually run rocketfuel-setup. The instructions on the
>> Running page work fine, and we recommend following
>> https://dev.launchpad.net/Running/LXC if you want it in a container.
> LXD rocks. I tried to start using LXC several times and it was a disaster.
> With LXD I can finally test stuff without ruining my system.

LXC works fine if you use it correctly, and it's documented well on the
page I linked. If LXD works for you, that's fine, but we can't help with
any issues with it.

>> If rocketfuel-setup doesn't work, we need precise details of what you
>> did and any error messages before we can help.
> http://piratepad.net/15min-launchpad-4
> After an hour of fetching files my connection dropped and the install failed.
> After restarting it looks like it will be another wasted hour. --shallow is
> really a must have for any DVCS.

As I've said, we will be moving to Git soon, which has clone --shallow
and is fast enough that you probably won't want --shallow anyway.

>>>> rocketfuel-setup will then avoid redownloading the data, as it's already
>>>> in the shared repository that it would normally create at
>>>> ~/launchpad/lp-branches.
>>>> The script will be replaced when Launchpad switches to Git, and the new
>>>> one will not be quite so picky.
>>> It seems that that `utilities/update-sourcecode` worked ok to populate the
>>> working copy after `bzr branch lp:launchpad`. It showed some errors, but
>>> they did't look critical. I only wish it did download all the branches
>>> by default,
>>> because I couldn't finish waiting for it to finish.
>> update-sourcecode downloads everything it needs by default. What didn't
>> it download?
> I decided to follow the rocketfuel path this time, so I can't say, but
> you should
> be able to see it for yourself by doing:
>   bzr clone lp:launchpad
>   cd launchpad
>   utilities/update-sourcecode

That sequence of commands works fine, but in general you can't just
randomly skip the entire installation procedure and expect what few
steps you do execute to still function.

Again, if you're going to report an error, it's imperative that you
actually report the details of the error. The only specific problem
you've described so far is that the installation script doesn't work
when your Internet connection is down, which is hardly something that we
can solve.


Attachment: signature.asc
Description: OpenPGP digital signature