linuxdcpp-team team mailing list archive
-
linuxdcpp-team team
-
Mailing list archive
-
Message #06631
Re: [Merge] lp:~klondike/adchpp/adchpp into lp:adchpp
2) cool little example. i indeed don't want anything more evolved than that. please rename (bzr mv) to example_bloom.lua; possibly add comments similar to those in example.lua that explain how the bloom Lua interface gets loaded.
Okey, I'll do it when I come back home. Comments included.
3) i figured that much; i was wondering why the "no-undef" had to sometimes be removed, on what seemed arbitrary to me (because not explained). can you detail "autoloading the plugin may not be a good idea"?
Well on one side you find that you need to link against Bloom.so which is already a problem (it won't work out of the box according to my tests),
The reason behind autoloading is that albeit the module will be loaded it won't be registered or initialized (it will just be compiled in) although the code may try to act as if it were. If you allow undefined symbols, when loading the luadchppbloom module if these can't be resolved the require will fail and thus the scripter can know that bloom is unusable because of this.
4) would it be possible to add an event in the bloom Lua interface that is fired when a new bloom table has been received from a client? this way, the bloom evaluation logic would happen exactly when needed rather than on state transitions. it would also remove the need for the oldstate changes which, while correct in theory, are burdensome.
I'm not familiar enough with the event interface to do this yet, I'm sorry.
5) there is a typo here:
228 + if not conf.CheckLuaPKG('socket', 'LuaSocket 2.0.2'): 229 + ret += dev.build('LuaFileSystem/') 230 + if not conf.CheckLuaPKG('lfs', 'LuaFileSystem 1.5.0'): 231 + ret += dev.build('LuaSocket/')
Is there? I really can't see it and I tried changing the required versions for the libraries and the code worked just fine.
I can try to get a more advanced version of the CheckLuaPKG though so non exact versions are required (as done now).
Anyway I also want to refactor the ruby code a little too, and add a getcon function to the dev system that will set up most of the values we set in each config.
--
https://code.launchpad.net/~klondike/adchpp/adchpp/+merge/150163
Your team Dcplusplus-team is subscribed to branch lp:adchpp.
References