← Back to team overview

lubuntu-desktop team mailing list archive

Re: Can't login through LXDM but console login *does* work [SOLVED!]


On 19 September 2010 15:44, Hilco Wijbenga <hilco.wijbenga@xxxxxxxxx> wrote:
> I have installed Lubuntu 10.04 on a laptop and since upgraded it to
> 10.04.1. At the time that I installed it, I noticed that login didn't
> work so I set it up to do autologin (i.e. I bypassed the whole LXDM
> login screen). That was several months ago and I'd forgotten why I had
> set it up like that. So I removed the autologin from
> /etc/lxdm/default.conf and /etc/lxdm/lxdm.conf. That's when I
> remembered why I had set it up like that. :-) So now I can't login any
> more. :-(
> The LXDM login doesn't work. I can type in the user name and password
> as often as I like, the system doesn't let me login. It just asks for
> the user name again. If I try it on the command line (CTRL-ALT-F2)
> then it works perfectly. The user exists and has a valid, working
> password. I've been googling for hours but I can't figure out what's
> wrong. I've tried a few random things (reinstall policykit-1, comment
> out pam_gnome_keyring in /etc/pam.d/lxdm) but nothing makes any
> difference.

I created a new user/password and I could use this user to login both
on the console and via the GUI. I then removed the existing user (the
one that could not login) and recreated it. Still no luck. Thoroughly
confused I took a brute force approach and reinstalled every package
... to no avail. I still could not login. Console login still worked,
mind you.

At that point I finally started to reason my way through the problem
and I hypothesized that the password (which contains a space) might be
the problem. Lo and behold, after changing the password to something
without a space, I could login. After I changed the password back to
something (different) with a space ("x y" specifically) I could,
again, not login.

So the problem is that the GUI login somehow does not allow/handle
passwords with a space. This sounds like a very nasty bug. Naturally,
there may be other problematic characters. Where should I report this?

Follow ups