← Back to team overview

maria-developers team mailing list archive

Re: Proposal to split @@optimizer_switch


> -----Original Message-----
> From: Sergey Petrunya [mailto:psergey@xxxxxxxxxxxx]
> Sent: Dienstag, 28. Juni 2011 08:17
> To: Vladislav Vaintroub
> Cc: maria-developers@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [Maria-developers] Proposal to split @@optimizer_switch
> On Tue, Jun 28, 2011 at 01:20:07AM +0200, Vladislav Vaintroub wrote:

> Ok. What syntax should be used to set all optimizer (or
> settings to their defaults?

set optimizer_*=default
set optimiizer_joincache_*=default

>  Lots of programming languages use xxx.yyy
> notation to denote access to member yyy of some composite entity xxx,  so
> when one writes
>   optimizer.join_cache.bka
> it hints that 'optimizer' is an entity that you could operate on as a
whole. If
> we use
>   optimizer_joincache_bka

> than personally for me it is not clear that 'optimizer' is an entity I
> operate on.

Well, plugins variables use the underscore notation now, and plugins are

I do not find the dot notation bad, it just does not look consistent with
the rest of variables.


Follow ups