← Back to team overview

maria-developers team mailing list archive

Re: Shared plugin library build question


On Fri, 2011-09-23 at 00:59 +0200, Vladislav Vaintroub wrote:

> Ok, libtool is being smart here..
> What happens if you change the definition of ha_federated_la_LDFLAGS  in federated/Makefile.am to
> ha_federated_la_LDFLAGS =	-module -rpath $(pkgplugindir) $(top_builddir)/libservices/libmysqlservices.a
> (Disclaimer, I have not tried it myself, the intention is to get rid of -l<libname> in favor of full path to the static library. This I think has more chances to be successful)

Well, the build works and I get a shared library but when I run the test
suite all my federated tests failed.  Looking at the log file from the
testing I see:

110923 14:22:01 [ERROR] Can't open shared library '/wsp/sje/mariadb/isvn2/mariadb-project/5.3.1.beta/install/lib/mysql/plugin/ha_federatedx.so' (errno: 2 Unsatisfied data symbol 'my_snprintf_service' in load module '/wsp/sje/mariadb/isvn2/mariadb-project/5.3.1.beta/install/lib/mysq)
110923 14:22:01 [ERROR] /wsp/sje/mariadb/isvn2/mariadb-project/5.3.1.beta/install/libexec/mysqld: unknown option '--federated'
110923 14:22:01 [ERROR] Aborting

Steve Ellcey

Follow ups