← Back to team overview

maria-developers team mailing list archive

Re: [Commits] Rev 3482: post review changes - interface (part 3)



> "madyncol" looks silly :)
> let's agree on one namespace prefix and use it everywhere. either it's
> ma_ like in
>   ma_open
>   ma_dyncol_create_many
>   ma_alloc
> or it's maria_ like in
>   maria_open
>   maria_dyncol_create_many
>   maria_alloc

I think we should use the vendor prefix "mariadb" instead of "maria"
(Maria was the previous name of the aria storage engine, but dynamic
columns work with all storage engines). This should be consistent for
all api functions.

mariadb_dyncol_[function_name] implies, that we are using a dynamic
column function for MariaDB.

For internal (non api functions) ma_ prefix is ok.