← Back to team overview

maria-developers team mailing list archive

Re: mariadb native client -- how to call RPMs?


On 09/04/2014 05:17 PM, Sergei Golubchik wrote:
Hi, Honza!

On Sep 03, Honza Horak wrote:
in Fedora, we're about to package mariadb-native-client, which we'd like
to utilize in Fedora as much as possible since using this piece of
software we can break the dependency on whole mariadb server package and
thus make the base system more compact.

Hm, does libmysqlclient depend on the server package?
Why would it?

Not really, I'm not considering the resulting binary RPMs, but components of the distro including sources as a whole. What I meant was that if anybody needs to e.g. build a mariadb connector for ruby, he needs to pull libmysqlclient and this one is built from 40MB large srpm of mariadb, which brings unnecessary complexity (rebases of whole server are more frequent, require more work to package them etc.) Having just tiny libmysqlclient would be much better for smaller core system.

However, since mariadb.org does not provide RPMs yet, I'm wondering
what would be the best name for such RPM package. The tar ball is
called mariadb_client.tar.gz but the project is called
mariadb-native-client on launchpad, which I like more btw. because it
differs more from mariadb-client package (which is actually a
subpackage of mariadb).

In our packages mariadb-client is the package with the tools, the
library is in mariadb-shared.

And the project is called mariadb/connector-c on github, so don't put
too much weight on the project name.

Right, we only want to follow Fedora guidelines that tell us to pay attention for picking up a proper name.

So, is mariadb-native-client a good choice or is there a better one?

How are packages with shared libraries usually named on Fedora?

Well, there is not only one pattern, but most common is either a subpackage with shared libraries called foo-libs or a pure library package called libfoo.

In our packaging we alias MariaDB-shared to mariadb-libs, so, I suppose
xxx-libs is what you usually use. Then I'd suggest mariadb-native-libs
or mariadb-lgpl-libs or something like that.

Personally, I do not like the license name in the name very much, but mariadb-native-libs or mariadb-connector-c sound fine.

Thanks for the ideas.