← Back to team overview

maria-developers team mailing list archive

Not able to run MariaDB after building from source



I am Sonali looking to participate in this years Google Summer of Code. I
was hoping to contribute to MariaDb.

I tried building MariaDb from source using instructions found here
<https://mariadb.com/kb/en/mariadb/generic-build-instructions/>. Configure,
make and make install were successful. But I faced problem under section
Starting MariaDB for the first time.

When I executed the step:

> scripts/mysql_install_db --user=mysql

I received an error saying:

> [Note] InnoDB: The InnoDB memory heap is disabled
> [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
> [Note] InnoDB: Memory barrier is not used
> [Note] InnoDB: Compressed tables use zlib 1.2.8
> [Note] InnoDB: Using Linux native AIO
> [Note] InnoDB: Using SSE crc32 instructions
> [Note] InnoDB: Initializing buffer pool, size = 128.0M
> [Note] InnoDB: Completed initialization of buffer pool
> [ERROR] InnoDB: Data file ./ibdata1 is of a different size 768 pages
> (rounded down to MB) than specified in the .cnf file 64000 pages!
> [ERROR] InnoDB: Could not open or create the system tablespace. If you
> tried to add new data files to the system tablespace, and it failed here,
> you should now edit innodb_data_file_path in my.cnf back to what it was,
> and remove the new ibdata files InnoDB created in this failed attempt.
> InnoDB only wrote those files full of zeros, but did not yet use them in
> any way. But be careful: do not remove old data files which contain your
> precious data!
> [ERROR] Plugin 'InnoDB' init function returned error.
> [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
> [ERROR] Unknown/unsupported storage engine: InnoDB
> [ERROR] Aborting
> Installation of system tables failed!  Examine the logs in
> ./data for more information.
> The problem could be conflicting information in an external
> my.cnf files. You can ignore these by doing:
>     shell> ./bin/scripts/mysql_install_db --defaults-file=~/.my.cnf
> You can also try to start the mysqld daemon with:
>     shell> ./bin/mysqld --skip-grant --general-log &
> and use the command line tool ./bin/mysql
> to connect to the mysql database and look at the grant tables:
>     shell> ./bin/mysql -u root mysql
>     mysql> show tables;

So I tried to run mysqld but that didn't work either. I had MySql installed
earlier, but I removed it because it was getting very confusing with that.

I also tried to run from source as mentioned here
But it gives the following error:

> ERROR 2002 (HY000): Can't connect to local MySQL server through socket
> '/tmp/mysql.sock' (111 "Connection refused")

I made sure that I uncommented lines from my.cnf which had sock information
under client and server.

Thanks in advance


Follow ups