← Back to team overview

maria-discuss team mailing list archive

Re: MariaDB for OpenSuSE 12.3


Hi, Peter!

On Nov 24, Peter Laursen wrote:
> Thanks Elena. That even I can understand.
> But error on installation of server packet "No packet found allowing for
> the action specified". I am simply launching YaST graphical interface from
> the context menu of the RPM file placed on my desktop ("install with packet
> manager"). There is a reference to some log with more details, but I don't
> know where it can be found.

I've tried to repeat this - but over ssh, so I used text-mode yast2.
Supposedly, selecting "install with packet manager" from the context
menu is equivalent to "sudo yast2 -i /path/to/file.rpm" (I don't know
for sure).

Here's the issue. MariaDB-server package depends on other MariaDB-*
packages. Normally yast or yum fetch dependencies automatically from a
repository. But you don't install from a repository, you install a
specific file. In this case yast cannot fetch dependencies. You have to
install either all packages in one command, like this:

  sudo yast2 -i MariaDB*server.rpm MariaDB*client.rpm MariaDB*common.rpm

or you can do it with GUI and a context menu - but you need to install
MariaDB*common.rpm first, then MariaDB*client.rpm, and only then you can
install MariaDB*server.rpm.

I tried both solutions - both worked.


P.S. Now, when we build for SuSE, I hope we will provide a proper
package repository and yast will be able to resolve dependencies automatically.

Follow ups