← Back to team overview

maria-discuss team mailing list archive

maria won't start after giving up on mysql 5.7


I have been trying for a week to get mysql 5.7 setup on raspbian and have thrown in the towel. I have now installed (tried to install) mariadb 10.1 and it seems to hang on install and then won't start
Let me try one more time .......

sudo apt autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 9,216 B disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 126235 files and directories currently installed.)
Removing default-mysql-server (1.0.2) ...
Setting up mariadb-server-10.1 (10.1.23-9+deb9u1) ...
Job for mariadb.service failed because the control process exited with error code.
See "systemctl status mariadb.service" and "journalctl -xe" for details.
invoke-rc.d: initscript mysql, action "start" failed.
● mariadb.service - MariaDB database server
Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled) Active: failed (Result: exit-code) since Tue 2017-10-24 13:25:21 MST; 60ms ago Process: 5576 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=1/FAILURE) Process: 5487 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= || VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ] && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/SUCCESS) Process: 5482 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS) Process: 5479 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
 Main PID: 5576 (code=exited, status=1/FAILURE)
   Status: "MariaDB server is down"

Oct 24 13:25:16 qa.com systemd[1]: Starting MariaDB database server...
Oct 24 13:25:18 qa.com mysqld[5576]: 2017-10-24 13:25:18 1996230656 [Note] /usr/sbin/mysqld (mysqld 10.1.…576 ... Oct 24 13:25:21 qa.com systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE Oct 24 13:25:21 qa.com systemd[1]: Failed to start MariaDB database server. Oct 24 13:25:21 qa.com systemd[1]: mariadb.service: Unit entered failed state. Oct 24 13:25:21 qa.com systemd[1]: mariadb.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package mariadb-server-10.1 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mariadb-server:
mariadb-server depends on mariadb-server-10.1 (>= 10.1.23-9+deb9u1); however:
  Package mariadb-server-10.1 is not configured yet.

dpkg: error processing package mariadb-server (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

any ideas?  Thank you!

Richard Whitney

May there always be tread and air in your tires and oatmeal and butter in
your bowl - Author Unknown