← Back to team overview

maria-discuss team mailing list archive

Re: Issues cross-compiling MariaDB for ARM


Okay, so after some more toil, I've managed to get it to compile.

However, when I run mysqld, I get the error "A newer kernel is required
to run this binary."

My cross compiler compiles for Linux 2.6.27, and the target kernel is - ancient I know, but I can't upgrade it.

If I run "file" on mysqld, I get the following:
./nas-sysroot/usr/local/mysql/bin/mysqld: ELF 32-bit LSB  shared object,
ARM, EABI5 version 1 (SYSV), dynamically linked (uses shared libs), for
GNU/Linux 2.6.27, not stripped

This all seems fine, so has anyone got any ideas why this is happening?


On 28/06/2019 17:50, Hamish MB wrote:
> I didn't realise, I assumed it was essential. Oops, sorry! I'll give
> that a go now.
> Hamish
> On 28/06/2019 17:17, Marko Mäkelä wrote:
>> Hamish,
>> The error comes from the Connect storage engine, which is a virtual
>> storage engine that connects to other servers. If you do not need
>> that, you can disable it. Similar storage engines are Federated,
>> FederatedX, Spider.
>> (which was part of my initial reply).
>> Best regards,
>> Marko
> _______________________________________________
> Mailing list: https://launchpad.net/~maria-discuss
> Post to     : maria-discuss@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~maria-discuss
> More help   : https://help.launchpad.net/ListHelp

Follow ups