← Back to team overview

openerp-community team mailing list archive

Convention for unported modules


Hi all,

Current lp2git migration steps <https://github.com/OCA/maintainers-tools/wiki/Migration-Launchpad-%E2%86%92-GitHub#migration-steps> tell you to rename unported modules with a suffix "_unported". This was a strategy Sandy found to have TravisCI and Flake8 ignore them, and Guewen included that in the migration docs, and I believe it already been adopted in some of the migrations to GitHub.

On the other hand, last November we also discussed here <https://lists.launchpad.net/openerp-community/msg04016.html> a convention to easily identify unported modules. I made the proposal to use a subdirectory, since I was working on a project where most modules were unported and often it wasn't easy to navigate around. We eventually agreed that a "__unported__" subdirectory could be used for that. I believe at the time most people didn't see that a necessity, so in practice it was not widely used.

My problem is that the new convention does not solve the initial problem: uncluttering repo root from unported modules. And I believe the subdirectory approach is also capable to do what's needed for TravisCI and Flake8.

So, my opinion is that we shoudl prefer the "__unported__" subdirectory convention over the "_unported" suffix convention.
I believe the impact on already migrated repos is negligible.

So I open the discussion on this, and of couse will follow whatever consensus comes out of it.

Best regards,
Daniel Reis

Follow ups