← Back to team overview

openstack team mailing list archive

Re: Multinode installation (with devstack on the master)


Hey Sagar,

I'll take a quick guess here that maybe your servers have host names that
don't resolve.  So for example, if host1 is 'server1' and host2 is
'server2' the vnc proxy may try connect using those hostnames (connecting
to the latter host would probably fail).  A quick fix could be to add an
entry in your master /etc/hosts for the second server's hostname.


On Fri, Dec 30, 2011 at 2:02 PM, Frost Dragon <frostdragon777@xxxxxxxxx>wrote:

> Hi,
>     Thanks for the replies. I tried a clean installation with eth1 as my
> flat interface and it worked perfectly well. I can now ping and SSH to my
> VMs on either node from the other. They're also getting their metadata
> correctly. Only problem is that I can't access VMs on the second node via
> the console on the dashboard running on the first node. I'm getting a
> 'Failed to connect to server' message. However, I can view the VMs running
> on the master node through the vnc console. Is this related to
> nova-vncproxy? The services I'm running on the second node are
> n-vol,n-cpu,n-net and n-api.
> Thanks and regards,
> Sagar

Follow ups