← Back to team overview

tomdroid-dev team mailing list archive

Re: Web sync branch hurdles


On Mon, Nov 9, 2009 at 1:36 PM, Benoit Garret
<benoit.garret_launchpad@xxxxxxxx> wrote:
> Thanks a lot for your feedback! Motivation is much more easy to find
> when you know people are actually using and testing the code.

Well, people in IRC and twitter/identi.ca are starting to bug me about
Tomboy/U1 support on their Android phones... ;-)

> On Sun, Nov 8, 2009 at 10:58 PM, Sandy Armstrong
> <sanfordarmstrong@xxxxxxxxx> wrote:
>> Hi Folks,
>> I finally got an Android environment set up (sadly, Eclipse just
>> failed totally in openSUSE, so I'm using my Mac for Android stuff).
> I also gave up on installing the Ubuntu Eclipse packages, installing
> plugins fails in every conceivable way. I usually download the tarball
> from eclipse.org and run it from my home dir.

Even that did not work for me in openSUSE 11.2.

>> I pulled Benoit's web sync branch and decided to play around and see if
>> I could get it to work with Ubuntu One.  The first thing I did was to
>> change the default sync backend pref from "sdcard" to "snowy", because
>> without a tomdroid directory on the SD card I was getting exceptions
>> on startup.
> I'll have to catch the exception anyway. My reasoning here was that
> the sd card sync should be the default because it doesn't have to be
> configured but if someone has an argument against it I'll gladly
> change this.

No, you're right.  Maybe if no "tomdroid" directory is found, there
should be some text like "no notes found, would you like to configure
web sync?".

>> The last thing I did was to change the oauth consumer pair
>> constants from "tomdroid"/"tomdroid" to "anyone"/"anyone".
>> With these changes I was able to get pretty far in the authentication
>> process, but not far enough.
> Then you got further than I did when I tried, I kept hitting internal
> server errors during the first part of the authentication. I gave up
> quickly for I didn't have any mean of knowing what really happened on
> U1.
>> When the callback URL (tomdroid://sync)
>> was called by the browser, it seemed like a new Tomdroid instance came
>> up (or at least, the welcome message was shown again), and then
>> nothing happened.  At this point I'm kind of out of time to keep
>> digging in today, but really I'm just not sure what the expected
>> behavior is when running Tomdroid from the web sync branch, in the
>> emulator, starting with an empty SD card.
> The menu should contain a sync item as soon as the authentication
> process is finished, but we really should inform the user about the
> progress.

Yeah, I would suggest that the welcome message not be shown...instead,
a screen (don't know the right android UI terminology here) stating
that auth was successful and sync is in progress (along with a
progress indicator) would really be best.  When the sync is done, it
should go straight to your notes.

> I tested U1 with the patch you provided below (which should be the
> only changes required to support oauth 1.0a). You're absolutely
> correct in your assumption that Tomdroid is handling the tomdroid://
> url, that's why another instance seems to be started (we should only
> show the popup on the first run). I get the following exception when
> trying to do the last part of the auth process:
> OAuthExpectationFailedException: Request token or token secret not set
> in server reply. The service provider you use is probably buggy.

That is the same exception I got, and tried ignoring, with
unsatisfactory results.  :-)  I'd really like to see the response sent
by U1 here...copying Signpost source directly in to Tomdroid bzr would
allow debugging deeper into Signpost, right?


Follow ups