← Back to team overview

ubuntu-phone team mailing list archive

Re: owncloud-client-cmd on the phone


That's awesome! Great work Filip!!!

It might be able to be created as a click package for the open (unconfined) store. I think there are other issues with file syncing through app confinement that need to be worked out (will happen eventually, not sure how it will implemented now). Could a simple gui be created with html5 & javascript? Not across UI's myself either, but excited to see which way this goes. Thanks for your work so far.


On 06/04/16 07:04, Filip Dorosz wrote:
Another update:

I have working client!
(No need to put phone in RW mode)

I pulled necessary packages from Debian sid:
and packed it so anyone can download it, extract and use:


This is owncloudcmd version 2.1.1 so its compatible with newer version of ownCloud server.

* upstart job + scripts to periodically run sync.
* gui for managing simple config file.(I'm not familiar with graphic programming in ubuntu-sdk so I'll need some help)
* click package (I don't know if this is even possible)

Filip Dorosz

W dniu 05.04.2016 o 19:50, Wayne Ward pisze:
Have you tried http Plus im certain the 1.7 version is to older client
for the server your running thats why i moved to to 1.8.1 Wayne
On Tuesday, 5 April 2016 18:29:40 BST, Filip Dorosz
<filip.dorosz@xxxxxxxxxxxxxxxx> wrote:
forgot to add:
I'd really appreciate if someone test it against their setup.

[1] http://people.rapidrage.com.pl/~filip/owncloud-1.7-armhf.zip

W dniu 05.04.2016 o 19:27, Filip Dorosz pisze:

I updated my setup [1] with some more libs and now I'm stuck with 403
error servers side (note: normal clients on desktop works)

Filip Dorosz

W dniu 05.04.2016 o 15:19, Filip Dorosz pisze:
Hi all.

I recently downloaded all dependencies needed by owncloud-client-cmd
1.7.0~beta1+really1.6.4+dfsg-1 from Vivid ports repository:
http://ports.ubuntu.com for armhf repository and stuffed in into local
dir and then adjusted LD_LIBRARY_PATH to include my new lib path.

And to my suprise... it worked! I've made some testing and
been unable to sync ~/Pictures/test with my OC but at least I have
working client.

I get following error so if anyone join me can try to troubleshoot it

04-05 14:58:28:423 Database Drivers could not be loaded.
04-05 14:58:28:423 Database Drivers could not be loaded.
04-05 14:58:28:423 Database Drivers could not be loaded.
04-05 14:58:28:423 Database Drivers could not be loaded.
04-05 14:58:28:424 Database Drivers could not be loaded.
04-05 14:58:28:424 Bailing out, DB failure

If anyone is interested here is zip file with owncloud-client-cmd and
needed libs. You just need to unzip it into your's phone HOME and merge
bin with your current ~/bin
Then you can use owncloudcmd in phone's terminal.

If we somehow make syncing work we may create simple bash script and
upstart job to automatically sync certain directories from the phone
to oc.
(tbh I already have these for rsync)

Filip Dorosz.

Follow ups