← Back to team overview

ubuntuone-users team mailing list archive

Re: Identifying Computers


Hi Peter,

So the problem here I suppose, is that your browser gets launched, and
you click the "accept" button in the window, and it then fails to
connect to afterward. Is that correct?

To provide a smoother user experience, we use the "callback" feature of
OAuth, and start a very tiny local web server instance on a random port,
which we tell the authentication site to call back to when finished.
This allows us to immediately get the access token and add it to the
keyring, without requiring extra intervention from the user. As soon as
our tiny web server gets redirect to, we redirect the browser back to
the https://ubuntuone.com/ site and shut down the local server instance,
to avoid keeping a server open and running on localhost.

If you're running a browser on a remote machine, this will break that
functionality, as "localhost" won't actually be your local host.

On Tue, 2009-06-30 at 17:23 +0200, Peter Funk wrote:
> So I've created a new user account on my computer 
> solely for the purpose of running firefox in this account
> and so with restricted rights (less group memberships, no access
> to my private data).  Instead of starting firefox directly
> I've a menu entry running the command
> 	ssh -X surferrole@localhost firefox
> to launch my web browser.  In the menu preferences->preferred applications
> (I hope it called so in english, because I run Gnome in
> German I translated this back) I've configured the following
> command as my preferred web browser command:
>         ssh surferrole@localhost firefox -new-tab "'%s'"
> For some reason the ubuntuone-client-applet was unable
> to deal with this somewhat special situation.  
> I finally found its logfile which was somewhat hidden in a subdirectory
> as $HOME/.cache/ubuntuone/log/oauth-login.log and pasted the URL
> from this logfile manually in new firefox browser window running on
> my own account.  That ugly workaround made it possible to continue
> a little bit.  But the "Go to Web" menu entry from the applet 
> still doesn't work as I would have expected:  It open a new tab in
> my firefox running as user "surferrole" instead of my account.
> But that's it.

Attachment: signature.asc
Description: This is a digitally signed message part

Follow ups