← Back to team overview

yade-users team mailing list archive

A strange error in installation yade-0.50.0 on Kubuntu 10.04


hi all,

When I
“sudo scons jobs=2 pretty=0 debug=1 PREFIX=/home/Kenny/YADE00051“
,I received the error message:

Checking for QGLViewer() in C++ library qglviewer... (cached) no
(OK, local version will be used instead)
Checking for vtkInstantiator::New() in C++ library vtkCommon... no

ERROR: Unable to compile with optional feature `vtk'.

If you are sure, remove it from features (scons
features=featureOne,featureTwo for example) and build again.
Note: You might have to add VTK header directory (e.g.
/usr/include/vtk-5.4) to CPPPATH.

So , I add the directory manually by
"sudo scons jobs=2 pretty=0 debug=1 PREFIX=/home/Kenny/YADE00051
however, another error came out:

Checking for C++ header file Eigen/Core... no

One of the essential libraries above was not found, unable to continue.

I tried CPPPATH="/usr/include/vtk-5.2;/usr/include/eigen2" . but receive
the same error as above. and in the config.log it shows :

scons: Configure: The original builder output was:
|/home/kenny/build-0.50-0/.sconf_temp/conftest_16.cpp <-
| |
| |#include "Eigen/Core"
| |
| |
g++ -o /home/kenny/build-0.50-0/.sconf_temp/conftest_16.o -c
-I/home/kenny/build-0.50-0/include/yade-0.50 -I/usr/include/python2.6
g++: no input files
sh: /usr/include/eigen2: Permission denied
scons: Configure: no

How to solve it?

Zhang Lin

Follow ups