← Back to team overview

yade-users team mailing list archive

Yade freezes when writing to memory


I couldn't post it to yade-dev@xxxxxxxxxxxxxxxxxxx.  Tried twice.  I
get this error when I run a file using the FileGenerator:

RuntimeError                              Traceback (most recent call last)

/home/booncw/yade/YADEbA/lib/yade-bA/py/yade/__init__.py in generateSlot(self)
  120                         print 'BUG: Saving to memory slots
freezes Yade (cause unknown). Cross fingers.'
  121                 #print 'Will save to ',filename

--> 122                 self.generator.generate(filename)
  123                 if self.generatorAutoCheck:
  124                         O.load(filename)

RuntimeError: unregistered class

And when I run a script using python, I get this error:

Welcome to Yade bzr2440
TCP python prompt on localhost:9000, auth cookie `sduayc'
XMLRPC info provider on http://localhost:21000
Running script mindlin_test.py
Traceback (most recent call last):
 File "/home/booncw/yade/YADEbA/bin/yade-bA", line 127, in runScript
 File "mindlin_test.py", line 38, in <module>
RuntimeError: unregistered class

Please help me. Anyone who has a clue. Haha.