← Back to team overview

zim-wiki team mailing list archive

[Bug 569091] Re: [win] cannot open another notebook


Problem seems to have been solved! Not sure exactly what solved it --
maybe I fixed a build script earlier, or maybe it's because some of the
libraries I used to build today are only weeks old releases.

I verify that gspawn-win32-helper.exe ends up in my build folder, and
when I install and run the final package, I am able to open two
notebooks using File -> Open.

** Changed in: zim
       Status: Confirmed => Fix Released

[win] cannot open another notebook
You received this bug notification because you are a member of Zim,
which is a bug assignee.

Status in Zim desktop wiki: Fix Released

Bug description:
When trying to open another Notebook and selecting one from the list or creating a new one, pressing OK only closes the selection dialog, but Zim does not open the notebook; it stays on the old notebook.

In the log, an error shows up:

ERROR: Failed running: ['C:\\Program Files (x86)\\Zim Desktop Wiki\\zim.exe', 'file:///D:/Dokumente/wiki/ToolEvaluierung', '--no-daemon']
Traceback (most recent call last):
  File "zim\applications.pyo", line 122, in spawn
GError: Hilfsprogramm (Invalid argument) konnte nicht ausgeführt werden

(last message should translate to "helper program (...) cannot be executed")

Using Windows-installer Zim-setup-0.46_2010-04-13.exe on Windows 7 64 bit.