kicad-developers team mailing list archive
Mailing list archive
PROPOSAL. Pcbnew anf GerbView layer names - can we improve them?
After a quick hystory check I noticed that in PCBNew (and in GerbView)
and maybe in other places, the names for layers has changed quite a
bit. Since I personally find (no offence) current naming a little
short I'd like to propose some changes. Please forgive me if I am
saying something stupid.
So here it goes, nn the left the current names and on the right my
propositions. At the bottom I also would like to propose some minor
name changes, please comment if you like.
Copper Layers -> Signal Layers
F.Cu -> Top Copper
B.Cu -> Bottom Copper
Inner1.Cu -> Mid Copper 1
Inner2.Cu -> Mid Copper 2
Technical Layers -> Non-copper Layers (or Mechanical Layers or
F.Adhes -> Top Adhesive
B.Adhes -> Bottom Adhesive
F.Paste -> Top Solder Paste
B.Paste -> Bottom Solder Paste
F.SilkS -> Top Silkscreen
B.SilkS -> Bottom Silkscreen
F.Mask -> Top Solder Mask
B.Mask -> Bottom Solder Mask
Dwgs.User -> Drawings
Cmts.User -> Comments
Eco1.User -> Extra 1
Eco2.User -> Extra 2
Edge.Cuts -> Edges
These changes will also imply the following changes:
Through Via -> Through Vias
Bl/Burried Via -> Blind/Burried Vias
Micro Via -> Micro Vias
Pads Front -> Top Pads
Pads Back -> Bottom Pads
Text Front -> Top Text
Text Back -> Bottom Text
No-Connects -> Unconnected
Modules Front -> Top Components
Modules Back -> Bottom Components
Values -> Footprint Values
References - Footprint Names
Here few questions to who knows the answers:
1) why is now a top layer named "Front Layer" and not "Top Layer". I
guess the anwer has to do with the "Select Layer Pair" Menu. I think
this menu can still stay.... even though I do not really see its use.
1) Applying these names the PCBNew "Layer Manager Toolbar" which maybe
should be called "Layer Manager" becomes larger and this might upset
Kicad mobile phone users. To satisfy them too, I'd like to propose a
smaller font and padding for it. This will maybe take up just few
pixels more than the current solution.
Can I please have your feedback guys before I just into this patch.
PS I'd like to be honest, to find some inspiration for this name thing
I had a look at gEDA, Protel and Altium naming conventions.