← Back to team overview

maria-developers team mailing list archive

Problems building debug version of MariaDB 5.5.32



I'm having problems building a Debug version of MariaDB 5.5.32.

(It's a new problem, I think; I'm almost positive it was working about two
weeks ago.)

Here is what I'm doing to build MariaDB:

$ cmake -DCMAKE_BUILD_TYPE=Debug .
$ make package

At 69% complete, I get about 14 lines like this:

[ 69%] Building CXX object
Linking CXX executable explain_filename-t
`.text._ZN7handler17ha_index_read_mapEPhPKhm16ha_rkey_function' referenced
in section `.note.stapsdt' of ../../sql/libpartition.a(ha_partition.cc.o):
defined in discarded section
char*, unsigned char const*, unsigned long, ha_rkey_function)]' of

followed by:

collect2: ld returned 1 exit status
make[2]: *** [unittest/mysys/explain_filename-t] Error 1
make[1]: *** [unittest/mysys/CMakeFiles/explain_filename-t.dir/all] Error 2
make: *** [all] Error 2

Some comments:
1. I'm running on CentOS 6.4:

$ uname -a
Linux weldon 2.6.32-358.18.1.el6.x86_64 #1 SMP Wed Aug 28 17:19:38 UTC 2013
x86_64 x86_64 x86_64 GNU/Linux

2. I've tried "cmake -DRPM=centos6 . " (without Debug specified) and it
works just fine.

3. I found the line in (282:) in ./CMakeLists.txt that reads
"ADD_SUBDIRECTORY(unittest/mysys)" and commented it out. Then the build
continued until it was trying to link mysqld ... and failed with the
similar errors at 99% completion. (I actually WANT mysqld, so I couldn't
comment it out too :-))

4. Something I read indicates that MariaDB requires a GCC build against
recent binutils. yum seems to indicate that both GCC and binutils are

5. The cmake option I'm using is the one for 5.5+ as instructed at

6. Yes, I also tried the old ./BUILD/compile-pentium64-debug-max (but it
failed similarly)

I THINK it's probably an incompatible version of some build tool on my
development box.

Thanks in advance for any advice.

Weldon Whipple

Follow ups