← Back to team overview

maria-discuss team mailing list archive

Re: MariaDB for OpenSuSE 12.3


Won't work. The problem is KDE it seems.  I use the XFCE desktop primarily
but did also installed KDE and a few more desktops (just in order to check
them). But the only KDE program that I really want is Amarok.

peter@linux-zayf:~/Skrivebord/MariaDB> sudo yast2 -i
DEPRECATED. Use zypper directly: zypper --non-interactive install
Indlæser softwarekildedata...
Læser installerede pakker...
Løser pakkeafhængigheder...
2 problemer:
Problem: mariadb-client-10.0.13-2.3.2.x86_64 konflikter med
namespace:otherproviders(mysql-client), der leveres af
Problem: MariaDB-server-10.0.15-1.x86_64 kræver MariaDB-client, men dette
krav kan ikke leveres

Problem: mariadb-client-10.0.13-2.3.2.x86_64 konflikter med
namespace:otherproviders(mysql-client), der leveres af
 Løsning 1: Følgende handlinger udføres:
  afinstallation af mariadb-client-10.0.13-2.3.2.x86_64
  afinstallation af akonadi-4.14.3-4.4.x86_64
  afinstallation af python-kde4-akonadi-4.14.3-4.3.x86_64
  afinstallation af plasma-addons-lancelot-4.14.3-8.3.x86_64
  afinstallation af plasma-addons-akonadi-4.14.3-8.3.x86_64
  afinstallation af korganizer-4.14.3-4.4.x86_64
  afinstallation af kontact-4.14.3-4.4.x86_64
  afinstallation af kmail-4.14.3-4.4.x86_64
  afinstallation af kdepim4-runtime-4.14.3-4.2.x86_64
  afinstallation af kdepim4-4.14.3-4.4.x86_64
  afinstallation af kaddressbook-4.14.3-4.4.x86_64
  afinstallation af knotes-4.14.3-4.4.x86_64
 Løsning 2: installér ikke MariaDB-client-10.0.15-1.x86_64

Vælg blandt løsningerne ovenfor med nummer eller skip, forsøg igen eller
annullér [1/2/s/f/a] (a): a  *<<-- this 'a' prompts automatically (gives me
no choice) and when I try same option from YaST GUI it just reinstalls what
it just removed. This is after I removed Amarok and a few other KDE
programs aswell as the old MariaDB server.. originally the conflict list
was longer!*


I have tried different things from command-line and GUI, but it seems that
I will need to remove a lot of KDE software making use of MySQL, if it
shall be possible to continue. Else it will not let me remove
mariadb-client-10.0.13. Did someone say *depencency hell* :-).

It will probably be easier to do a fresh install of SuSE without KDE!
Unless your RPMs can handle the conflicts (replacing themselves with what
is already installed).Restoring snapshot!

-- Peter

On Mon, Nov 24, 2014 at 3:54 PM, Peter Laursen <peter_laursen@xxxxxxxxxx>

> And teh *bonus question*.  What should I remove and not remove before
> installing your packages?
> peter@linux-zayf:~> rpm -qa | grep mysql
> libmysqlclient18-10.0.13-2.3.2.x86_64
> libqt4-sql-mysql-4.8.6-4.4.1.x86_64
> php5-mysql-5.6.1-4.1.x86_64
> libmysqld18-10.0.13-2.3.2.x86_64
> libmysqlcppconn6-1.1.2-6.2.2.x86_64
> libreoffice-base-drivers-mysql-
> peter@linux-zayf:~> rpm -qa | grep maria
> mariadb-client-10.0.13-2.3.2.x86_64
> mariadb-errormessages-10.0.13-2.3.2.x86_64
> mariadb-10.0.13-2.3.2.x86_64
> peter@linux-zayf:~>
> -- Peter
> On Mon, Nov 24, 2014 at 3:36 PM, Peter Laursen <peter_laursen@xxxxxxxxxx>
> wrote:
>> Thanks a lot. I will try this (tomorow probably).
>> -- Peter
>> On Mon, Nov 24, 2014 at 3:26 PM, Sergei Golubchik <serg@xxxxxxxxxxx>
>> wrote:
>>> Hi, Peter!
>>> On Nov 24, Peter Laursen wrote:
>>> > Thanks Elena. That even I can understand.
>>> >
>>> > But error on installation of server packet "No packet found allowing
>>> for
>>> > the action specified". I am simply launching YaST graphical interface
>>> from
>>> > the context menu of the RPM file placed on my desktop ("install with
>>> packet
>>> > manager"). There is a reference to some log with more details, but I
>>> don't
>>> > know where it can be found.
>>> I've tried to repeat this - but over ssh, so I used text-mode yast2.
>>> Supposedly, selecting "install with packet manager" from the context
>>> menu is equivalent to "sudo yast2 -i /path/to/file.rpm" (I don't know
>>> for sure).
>>> Here's the issue. MariaDB-server package depends on other MariaDB-*
>>> packages. Normally yast or yum fetch dependencies automatically from a
>>> repository. But you don't install from a repository, you install a
>>> specific file. In this case yast cannot fetch dependencies. You have to
>>> install either all packages in one command, like this:
>>>   sudo yast2 -i MariaDB*server.rpm MariaDB*client.rpm MariaDB*common.rpm
>>> or you can do it with GUI and a context menu - but you need to install
>>> MariaDB*common.rpm first, then MariaDB*client.rpm, and only then you can
>>> install MariaDB*server.rpm.
>>> I tried both solutions - both worked.
>>> Regards,
>>> Sergei
>>> P.S. Now, when we build for SuSE, I hope we will provide a proper
>>> package repository and yast will be able to resolve dependencies
>>> automatically.

Follow ups