← Back to team overview

ubuntu-waterloo-region team mailing list archive

Problem with XBMC?


I'm not getting anywhere with posting a problem to the internet forums, so
I thought I'd come here to the experts...

I'm having a problem with one of my Linux boxes, and I'm worried that it
might be a problem with XBMC.

I have a Synology NAS box on which I keep my videos. This folder is shared
out using NFS.

One machine of mine, running Ubuntu 13.10 has been having problems
accessing this shared folder. None of the other machines in the network
(including other 13.10 machines) are having any problems.

A few days ago I did a wipe and load of the problem machine, set up the
shares then watched a movie. It all worked well. Then the next day it's
back to the same errors as before.

I try to open the share in Nautilus or even from the desktop and I get the

This location could not be displayed.  You do not have the permissions
necessary to view the contents of "(name of share)"

Absolutely nothing has been changed since it was all working right the
first night!

If I go to the terminal and try to do a directory listing, I get:

ls: cannot access (share name): Permission denied

showmount -e (ip address) shows the correct share in the list.

The FSTAB command is as: /home/(user)/videosharename nfs
rw,hard,intr,nolock 0 0
This FSTAB statement has always worked with the Synology shares (at least,
since Ubuntu 13.04).

I've done a wipe and load three times now trying to clean out any possible
bugs, but I'm starting to doubt it's the configuration since it works fine,
then mysteriously dies on me.

After each wipe and load I install and configure Samba and NFS:

sudo apt-get install samba samba-common
sudo apt-get install python-glade2
sudo apt-get install system-config-samba
sudo apt-get install nfs-common

Here's the fun part: I can work my way through Nautilus via Browse Network
and eventually find the very shares that I just got denied to through the
direct links.

Now the reason I mentioned XBMC is because, as I mentioned, I watched a
movie when the whole thing was working (using XBMC) and that's when the
problems started.  I haven't run XBMC on the other Linux machines yet, and
they're still working (not the best deductive reasoning, I know...)

This should be the most recent version of XBMC, as I installed it from
scratch after the wipe and load.

Most puzzling!!

Follow ups