← Back to team overview

zim-wiki team mailing list archive

Re: Zim 0.26 released !


Rui Nibau wrote:
Just opening a ".gjots" file with zim should open it as a read-only notebook in zim. Still experimenting with this, included it because I needed some other patches from te same source tree. So please give me feedback if you actually use this.

Yes, that's what i tried, but it always failed.

(1) Created a gjots test file (test.gjots) with gjots2 2.3.7 :

	Test de fichier gjots

The type MIME of the file is good (application/x-gjots).

(2) Ran zim with the command line :

	zim -D test.gjots

I also tried :

	zim -p reader -D test.gjots

What is going wrong here is that zim thinks it is a notebook name because there is no "/" in it. Using "zim ./test.gjots" should work. Probably I should consider this a bug and check all names also as file in the local dir.

(3) So, I created a virtual entry in the notebooks.list file :

	Gjots	~/test.gjots

(4) Ran zim with the command line

	zim -D Gjots

But it still doesn't work.

Strange, this should work as well; just tested it without problem.

BTW, it's not a critical point. As an old outliner user, i have a lot of
datas in a lot of different file formats. That's why i'm writing an
outliner converter since a couple of months (well, when i have time),
above all to recover datas saved with Keynote, an old Windows app. So i
worked on a Keynote -> gjots, a Keynote -> Zim and a gjots <-> zim
converters, all in php. Time to finish the work and, maybe, rewrite the
last converter in perl to make it a zim plugin, starting with what you
have done in lib/Zim/Store/Gjots.pm.

In theory you should be able to do a commandline command to have zim export a gjots notebook to a zim notebook. Just tested it but it doesn't work :( Give me a few days and I'll push a fix to the bazaar tree.



Follow ups