← Back to team overview

zim-wiki team mailing list archive

Re: Zim .54 on Windows Vista Doesn't Start


Just wanted to say thank you. I have tested both the Portable Apps Version and the Installed Version on Windows Vista, and they are working great. I love having the bug fixes in this version.
| Steve |
| mowestusa@xxxxxxxxx      |

 From: Brendan Kidwell <snarf@xxxxxxxxx>
To: Brendan Kidwell <snarf@xxxxxxxxx> 
Cc: Zim-wiki Launchpad Mailing List <zim-wiki@xxxxxxxxxxxxxxxxxxx> 
Sent: Friday, February 17, 2012 7:00 PM
Subject: Re: [Zim-wiki] Zim .54 on Windows Vista Doesn't Start
Okay, second try...

web page: http://www.glump.net/software/zim
desktop install:
portable install:

My build from last month that's giving some of you trouble was done
with Windows 2008. I suspect some magic is preventing me from making a
stable build in Windows 2008 which will run on Windows 7 and Windows
XP in some cases.

I found an clean Windows XP SP3 VM from last September which had only
IE 8 installed. I Windows Updated it, backed it up, and cloned it.

Virtual Machine A: I downloaded the exact source code I used last
month ( lp:~bkidwell/zim/pyzim-win-installer rev 470 -- which has
since been merged into the trunk). I ran the build. I copied the
installers out of this VM.

Virtual Machine B: (Has no Python or GTK or anything on it.) I tried
each of the two builds I just made. I rolled back to a clean snapshot
before each try. Both installers worked and I was able to open and
edit notebooks.

If you had trouble with my first Zim 0.54 for Windows build, please
try the following:
* Download your preferred installer from the URLs above -- portable or
desktop -- and run it, replacing what you have.
* If that doesn't run, try running Windows Update until you have no
more required updates to install including all available Service
* If it still doesn't work, are you using an older version of Internet
Explorer on Windows XP? If this is a problem, I have no idea why it's
a problem, but I had Windows XP SP3 and IE 8, and it worked.

I hope this helps.

Brendan Kidwell

On Sun, Jan 29, 2012 at 11:24 PM, Brendan Kidwell <snarf@xxxxxxxxx> wrote:
> All, it's going to take me another few days to track down this
> problem. I suspect it's a missing DLL -- not sure if it's a system
> library you ought to have, or a missing inclusion from the GTK
> distribution into Zim. I haven't had a chance to look into it yet.
> Thanks for your patience.
> On Fri, Jan 27, 2012 at 5:56 PM, mowestusa <mowestusa@xxxxxxxxx> wrote:
>> Sorry that it took me a few days to run the debug of Zim .54. Below, you
>> will find the information. I hope that it helps diagnose the issue that I'm
>> having with Zim .54 on Vista 32bit. Thanks for your help.

Mailing list: https://launchpad.net/~zim-wiki
Post to     : zim-wiki@xxxxxxxxxxxxxxxxxxx
Unsubscribe : https://launchpad.net/~zim-wiki
More help   : https://help.launchpad.net/ListHelp