← Back to team overview

hybrid-graphics-linux team mailing list archive

Re: external monitors and bumblebee


Hi all,

I use file enclosed on my laptop (I put them in /etc/bumblebee).

I install synergy and use switch.sh to enable hdmi port (it works too with
displayport using enclosed xorg.conf.nvidia.displayport file but I don't
need it so...)

After this to launch application on second desktop :
DISPLAY=:8 command (command is displayed on hdmi port instead of laptop one)

I relaunch switch.sh to stop multi display (I have linked this script to
specific key...)

I do not have extended desktop with this solution (only the command

If someone have a better solution, I will be happy to try it (extended
desktop display or clone could be better than my actual solution...)

Anyway, if this can help someone...


On Sun, Aug 5, 2012 at 5:49 PM, Jardi A. Martinez Jordan <jardiamj@xxxxxxxxx
> wrote:

> On 08/03/2012 03:49 AM, Tomáš Janoušek wrote:
>> Hi,
>> On Fri, Aug 03, 2012 at 03:10:08AM -0700, Jardi Martínez wrote:
>>> OK, there is a Backtrace in the /var/log/Xorg.0.log.old unfortunately I
>>> have no idea what it means, I hope someone can help me with this, so here
>>> it is:
>>> [   113.697] Backtrace:
>>> [   113.697] 0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x7fc4fa5c1796]
>>> [   113.697] 1: /usr/bin/Xorg (0x7fc4fa443000+0x1822b9) [0x7fc4fa5c52b9]
>>> [   113.697] 2: /lib/x86_64-linux-gnu/**libpthread.so.0
>>> (0x7fc4f976b000+0xf030) [0x7fc4f977a030]
>>> [   113.697] 3: /usr/lib/xorg/modules/drivers/**intel_drv.so
>>> (0x7fc4f63a7000+0x132f6) [0x7fc4f63ba2f6]
>>> [   113.697] 4: /usr/lib/xorg/modules/drivers/**intel_drv.so
>>> (0x7fc4f63a7000+0x19869) [0x7fc4f63c0869]
>>> [...]
>> It means it indeed crashes in the intel driver, but since the library is
>> stripped of debugging information, it tells us nothing else.  Just try the
>> 2.20 patch and if that doesn't help, install debugging information and get
>> the nearest local guru to help you getting a proper backtrace out of that.
>> It's impractical to do this over e-mail.
>> Regards,
> Hi,
> I can confirm that xserver-xorg-video-intel version 2.20.2 with your patch
> fixes this problem. I had some troubles reinstalling bumblebee after
> installing the new version of the Intel driver but after getting it sorted
> out, I no longer see this problem.
> I am traveling right now, so I haven't try to connect it to my TV, I'll do
> try when I get back home tomorrow.
> Thanks,
> Jardi.
> ______________________________**_________________
> Mailing list: https://launchpad.net/~hybrid-**graphics-linux<https://launchpad.net/~hybrid-graphics-linux>
> Post to     : hybrid-graphics-linux@lists.**launchpad.net<hybrid-graphics-linux@xxxxxxxxxxxxxxxxxxx>
> Unsubscribe : https://launchpad.net/~hybrid-**graphics-linux<https://launchpad.net/~hybrid-graphics-linux>
> More help   : https://help.launchpad.net/**ListHelp<https://help.launchpad.net/ListHelp>

Authesserre Samuel

Attachment: bumblebee.conf.hdmi
Description: Binary data

Attachment: switch.sh
Description: Bourne shell script

Attachment: synergy.conf
Description: Binary data

Attachment: xorg.conf.nvidia.hdmi
Description: Binary data

Attachment: xorg.conf.nvidia.displayport
Description: Binary data