← Back to team overview

hybrid-graphics-linux team mailing list archive

Re: Mac Book Pro 6, 2 and Ubuntu 12.04 not working as expected


El 26/10/12 00:32, adrian15 escribió:
El 26/10/12 00:13, Andreas Heider escribió:
Ah, I just realized my email from yesterday got lost somewhere, so here
it is again:

Hi Adrian,

The reason why it might not work is that those instructions are quite a
bit outdated, sorry.
I also thought that but I had to try it.

But I see you're using the BIOS boot with hacks to activate the intel
card, that could be a problem.
Well, BIOS installation of 12.04 and BIOS boot of 12.04, that's what the
howto suggested.

Also, the kernel you're using is pretty old, most of the gmux stuff is
already in mainline since 3.6, I tried 3.6 plus this patchset:

on my mbp 6,2 (booting with EFI) some time ago and it worked.

I hope this helps you at least a bit.
It was as old as the suggested howto said.. well.. I suppose It would be
have worked if I had git cloned ubuntu-kernel-mbp repo but using not
current head but a commit from about the howto publication date. I
didn't think of that.

I'll take a look on this new stuff... probably on next weekend. I'll
document it too and post it around here.

I'm not used on how the kernel gets developed... Do you know if there is
any easy way to track if the patch you mentioned has got into mainline
apart from asking Seth Forshee himself?

If there isn't I can always compare the patch lines with the current
code ;).

Thank you for all your help again.



In the next days, probably today, I'm going to update my Debian Unstable to use Linux 3.8 (thanks to experimental branch and pinning).

What I wanted to mention is that I had sent an email to Seth Forsee (the patchset developer that you mentioned) and he told me that:

* He doesn't know if the patchset would work in my model because he was never able to test it in my model (MBP 6,2) * Depending of the behaviour of my firmware I might not need any patches because some older models were reported to work with 3.6. * I might need to use nouveau instead of nvidia propietary driver for switching to work. * The patches, which was never accepted upstream because it was kind of a last resort can be found at: https://patchwork.kernel.org/patch/1429901/ (I just save it here so that if vanilla kernel doesn't do the trick I would try them).

I'll keep you informed about what happens with my updated Debian and I will probably document it somewhere.

Support free software. Donate to Super Grub Disk. Apoya el software libre. Dona a Super Grub Disk. http://www.supergrubdisk.org/donate/