← Back to team overview

maria-discuss team mailing list archive

Re: MariaDB for OpenSuSE 12.3


oups, sorry, I missed your

peter@linux-hwpu:~> rpm -qa | grep maria


Le 25/11/2014 14:07, jocelyn fournier a écrit :

Perhaps try to grep mariadb instead of mysql ?


Le 25/11/2014 14:00, Peter Laursen a écrit :
wrong again .. the server. clients, and CONNCT engine are installed. and sever is running

peter@linux-hwpu:~> mysql
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 4
Server version: 10.0.15-MariaDB MariaDB Server

Copyright (c) 2000, 2014, Oracle, SkySQL Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> show databases
    -> ;
| Database           |
| information_schema |
| test               |
2 rows in set (0,01 sec)

MariaDB [(none)]> show engines;
| Engine | Support | Comment | Transactions | XA | Savepoints |
| MEMORY | YES | Hash based, stored in memory, useful for temporary tables | NO | NO | NO | | CSV | YES | CSV storage engine | NO | NO | NO | | MyISAM | YES | MyISAM storage engine | NO | NO | NO | | BLACKHOLE | YES | /dev/null storage engine (anything you write to it disappears) | NO | NO | NO | | MRG_MyISAM | YES | Collection of identical MyISAM tables | NO | NO | NO | | CONNECT | YES | Management of External Data (SQL/MED), including many file formats | NO | NO | NO | | FEDERATED | YES | FederatedX pluggable storage engine | YES | NO | YES | | ARCHIVE | YES | Archive storage engine | NO | NO | NO | | InnoDB | DEFAULT | Percona-XtraDB, Supports transactions, row-level locking, and foreign keys | YES | YES | YES | | PERFORMANCE_SCHEMA | YES | Performance Schema | NO | NO | NO | | Aria | YES | Crash-safe tables with MyISAM heritage | NO | NO | NO |
11 rows in set (0,00 sec)

MariaDB [(none)]>

-- Peter

MariaDB [(none)]>

.. but the"rpm" command does not return it?

-- Peter

On Tue, Nov 25, 2014 at 1:38 PM, Peter Laursen <peter_laursen@xxxxxxxxxx <mailto:peter_laursen@xxxxxxxxxx>> wrote:

    oops .. it seems that I am wrong!

    peter@linux-hwpu:~> rpm -qa | grep mysql
    peter@linux-hwpu:~> rpm -qa | grep maria
    peter@linux-hwpu:~> ^C

    .. so no server is installed now, it seems!

    -- Peter

    On Tue, Nov 25, 2014 at 1:37 PM, Peter Laursen
    <peter_laursen@xxxxxxxxxx <mailto:peter_laursen@xxxxxxxxxx>> wrote:

        I did a fresh install of SuSe 1.3 with only XFCE desktop. I
        installed the "LAMP Server" from the Installation menu.  next
        I installed Amarok and its dependencies (and it was not a
        showstpper if not installed with the full KDE).

        Problems still occurring
        1) I had to uninstall
        2) the command line yast2 command syntax failed, but  I was
        able to isntall the packages one-by-one in te order specified
        3) after rinstallation the service does no appear in YaST
        'Service management' GUI. It definitely shold on SuSE.

        (detals of the error in 1) above

        3 nye pakker der installeres.
        Samlet downloadstørrelse: 95,3 MiB. Allerede cachet: 0 B
         Efter transaktionen
        vil yderligere 522,2 MiB blive brugt.
        Vil du fortsætte? [j/n/? vis alle tilvalg] (j): j
        Henter pakke MariaDB-common-10.0.15-1.x86_64
         (1/3),  19,9 KiB (173,9 KiB udpakket)
        Henter pakke MariaDB-client-10.0.15-1.x86_64
         (2/3),  24,3 MiB (147,7 MiB udpakket)
        Henter pakke MariaDB-server-10.0.15-1.x86_64
         (3/3),  71,0 MiB (374,4 MiB udpakket)
        Tjekker for filkonflikter:
        Fandt 1 filkonflikt:

        File /usr/lib64/libmysqld.so.18
          from install of
         MariaDB-server-10.0.15-1.x86_64(Cache for rene RPM-filer)
          conflicts with file from package

        Filkonflikter forekommer når to pakker forsøger at installere
        filer med samme navn, men forskelligt indhold. Hvis du
        fortsætter vil filer i konflikt blive erstattet, hvorved det
        tidligere indhold mistes.
        Vil du fortsætte? [ja/nej] (nej): nej

        Der opstod en problem under eller efter installation eller
        fjernelse af pakker:
        Installation aborted by user  <-- what is not true. I was not
        given a choice!)

        Please test your RPMs for use in GUI environments.  Currently
        it is hardly usable here. Also consider that people may
        already have installed the server shipping with the distro. I
        guess i would work if KDE was not installed and MySQL/MariaDB
        also was not. I think it would be prefaerable if MariaDBs
        RPMs for SuSE had the same structure and dependencies as
        those shipped by SuSE so that existing installation could be
        upgraded. But that is a rather 'unqualified opinion'. You
        probably have reasons to do as you do.

        -- Peter

        On Mon, Nov 24, 2014 at 8:22 PM, Peter Laursen
        <peter_laursen@xxxxxxxxxx <mailto:peter_laursen@xxxxxxxxxx>>

            Won't work. The problem is KDE it seems.  I use the XFCE
            desktop primarily but did also installed KDE and a few
            more desktops (just in order to check them). But the only
            KDE program that I really want is Amarok.

            peter@linux-zayf:~/Skrivebord/MariaDB> sudo yast2 -i
            DEPRECATED. Use zypper directly: zypper --non-interactive
            install ./MariaDB-10.0.15-opensuse13_1-x86_64-server.rpm
            Indlæser softwarekildedata...
            Læser installerede pakker...
            Løser pakkeafhængigheder...
            2 problemer:
            Problem: mariadb-client-10.0.13-2.3.2.x86_64 konflikter
            med namespace:otherproviders(mysql-client), der leveres
            af MariaDB-client-10.0.15-1.x86_64
            Problem: MariaDB-server-10.0.15-1.x86_64 kræver
            MariaDB-client, men dette krav kan ikke leveres

            Problem: mariadb-client-10.0.13-2.3.2.x86_64 konflikter
            med namespace:otherproviders(mysql-client), der leveres
            af MariaDB-client-10.0.15-1.x86_64
             Løsning 1: Følgende handlinger udføres:
              afinstallation af mariadb-client-10.0.13-2.3.2.x86_64
              afinstallation af akonadi-4.14.3-4.4.x86_64
              afinstallation af python-kde4-akonadi-4.14.3-4.3.x86_64
              afinstallation af plasma-addons-lancelot-4.14.3-8.3.x86_64
              afinstallation af plasma-addons-akonadi-4.14.3-8.3.x86_64
              afinstallation af korganizer-4.14.3-4.4.x86_64
              afinstallation af kontact-4.14.3-4.4.x86_64
              afinstallation af kmail-4.14.3-4.4.x86_64
              afinstallation af kdepim4-runtime-4.14.3-4.2.x86_64
              afinstallation af kdepim4-4.14.3-4.4.x86_64
              afinstallation af kaddressbook-4.14.3-4.4.x86_64
              afinstallation af knotes-4.14.3-4.4.x86_64
             Løsning 2: installér ikke MariaDB-client-10.0.15-1.x86_64

            Vælg blandt løsningerne ovenfor med nummer eller skip,
            forsøg igen eller annullér [1/2/s/f/a] (a): a */<<-- this
            'a' prompts automatically (gives me no choice) and when I
            try same option from YaST GUI it just reinstalls what it
            just removed. This is after I removed Amarok and a few
            other KDE programs aswell as the old MariaDB server..
            originally the conflict list was longer!/*

            I have tried different things from command-line and GUI,
            but it seems that I will need to remove a lot of KDE
            software making use of MySQL, if it shall be possible to
            continue. Else it will not let me remove
            mariadb-client-10.0.13. Did someone say *depencency hell*

            It will probably be easier to do a fresh install of SuSE
            without KDE! Unless your RPMs can handle the conflicts
            (replacing themselves with what is already
            installed).Restoring snapshot!

            -- Peter

            On Mon, Nov 24, 2014 at 3:54 PM, Peter Laursen
            <mailto:peter_laursen@xxxxxxxxxx>> wrote:

                And teh *bonus question*.  What should I remove and
                not remove before installing your packages?

                peter@linux-zayf:~> rpm -qa | grep mysql
                peter@linux-zayf:~> rpm -qa | grep maria

                -- Peter

                On Mon, Nov 24, 2014 at 3:36 PM, Peter Laursen
                <mailto:peter_laursen@xxxxxxxxxx>> wrote:

                    Thanks a lot. I will try this (tomorow probably).

                    -- Peter

                    On Mon, Nov 24, 2014 at 3:26 PM, Sergei Golubchik
                    <serg@xxxxxxxxxxx <mailto:serg@xxxxxxxxxxx>> wrote:

                        Hi, Peter!

                        On Nov 24, Peter Laursen wrote:
                        > Thanks Elena. That even I can understand.
                        > But error on installation of server packet
                        "No packet found allowing for
                        > the action specified". I am simply
                        launching YaST graphical interface from
                        > the context menu of the RPM file placed on
                        my desktop ("install with packet
                        > manager"). There is a reference to some log
                        with more details, but I don't
                        > know where it can be found.

                        I've tried to repeat this - but over ssh, so
                        I used text-mode yast2.
                        Supposedly, selecting "install with packet
                        manager" from the context
                        menu is equivalent to "sudo yast2 -i
                        /path/to/file.rpm" (I don't know
                        for sure).

                        Here's the issue. MariaDB-server package
                        depends on other MariaDB-*
                        packages. Normally yast or yum fetch
                        dependencies automatically from a
                        repository. But you don't install from a
                        repository, you install a
                        specific file. In this case yast cannot fetch
                        dependencies. You have to
                        install either all packages in one command,
                        like this:

                          sudo yast2 -i MariaDB*server.rpm
                        MariaDB*client.rpm MariaDB*common.rpm

                        or you can do it with GUI and a context menu
                        - but you need to install
                        MariaDB*common.rpm first, then
                        MariaDB*client.rpm, and only then you can
                        install MariaDB*server.rpm.

                        I tried both solutions - both worked.


                        P.S. Now, when we build for SuSE, I hope we
                        will provide a proper
                        package repository and yast will be able to
                        resolve dependencies automatically.

Mailing list:https://launchpad.net/~maria-discuss
Post to     :maria-discuss@xxxxxxxxxxxxxxxxxxx
Unsubscribe :https://launchpad.net/~maria-discuss
More help   :https://help.launchpad.net/ListHelp

Follow ups