← Back to team overview

maria-discuss team mailing list archive

Re: Maria-db refuses to start


Op 07-12-2022 om 23:14 schreef Reindl Harald:

Am 07.12.22 um 16:53 schrieb Jogchum Reitsma:
Op 07-12-2022 om 12:15 schreef Reindl Harald:

Am 07.12.22 um 10:27 schrieb Jogchum Reitsma:
Sorry, my bad: of course I should have started mysqld, not mysql.....

besides that you should notice when you try to start a non-existing service what is really bad: you randomly mix "mysqld", "mysql" and "mariadb" as service name in your posts

in the worst case they are really existing but doing different things

Starting 10.7.7 works, and indeed recreates ib_logfile0. All my databases are there, no corruption AFAICS.

Shut it down with kill -15, and the logfile reports a normal shutdown

you shouldn't use "kill" at all fro shutdown when you start something as systemd-unit

I  started the he 10.7.7 version not through systemd, but by issuing /usr/local/mariadb-10.7.7-linux-systemd-x86_64/bin/mysqld in the terminal, as advised earlier in this conversation.

as which user?

if it's a different one maybe permissions are a problem (again)
Well, as a normal user. But as I stated, there is no problem with *this* command: this works, and I get a functioning db-system.

"Sorry, my bad: of course I should have started mysqld, not mysql" should have been obvious - i mean a sevrer is a background process versus an interactive sql shell
That is what I meant to say, I inadvertently forgot the 'd' after 'mysql'.

This way I managed to get a working db-server, and access to my data.

I stopped that by SIGQUIT, and this gives a correct shutdown.

15 is SIGTERM, lucky you didn't find the number for SIGQUIT
I always use the numbers, not the variant in words.

After that, I tried to start the version that comes with the OS (OpenSuse Thumbleweed) trough systemctl start mariadb, without success.

so the problem is still not really solved?

if that's the case for the sake of god dump your data as soon as you get the server running,
As I said, I can get the server running, only not through systemd
remove all nonsense and mysql-data from the system, start from scratch and import the dumps as it's normal for postgresql

my mysql-data dirs date back to 2002 and where used on MacOS, Linux and Widows over the past years, so strange when mysql/mariadb acts that strange, but so be it

Hope this clarifies the steps taken

that whole thread is a mess....

Mailing list: https://launchpad.net/~maria-discuss
Post to     : maria-discuss@xxxxxxxxxxxxxxxxxxx
Unsubscribe : https://launchpad.net/~maria-discuss
More help   : https://help.launchpad.net/ListHelp

Follow ups