← Back to team overview

yade-users team mailing list archive

Re: Compilation error with newest yade-0.10.0


I think have solved the problem for the function of "findType", because I was 
using a version of gcc-4.1.0 (this version was provided by openfoam, I don't 
know (or if there is) the difference between this version and the standard 
version of 4.1.0), after change back to gcc-4.0.2, either the newest yade0.10, 
or the previous version 0.946 can both be compiled successfully.

However, my current problem is that I can compile and run YADE as root user (I 
installed "yade" into /usr/local/bin, but not as a common user "fchen", after 
I compiled YADE (the same version 0.10) and installed it into 
/home/fchen/YADE, added one line to home/.bashrc file: 
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/home/fchen/YADE/lib/yade/yade-libs
 and went into folder ~YADE/bin and typed ./yade, the following error occured:
[fchen@MapleLinux bin]$ ./yade
Constructing ClassFactory  (if multiple times - check '-rdynamic' flag!)
Constructing SerializableSingleton  (if multiple times - check '-rdynamic' 
flag! )
Constructing Omega  (if multiple times - check '-rdynamic' flag!)
loading configuration file: /home/fchen/.yade/preferences.xml
Please wait while loading plugins.
Plugins loaded.
terminate called after throwing an instance of 'FactoryCantCreate'
  what():  ClassFactory::create - cannot create class named: QtGUI
The problem is, as a root user, the yade's QTGUI runs well, but after I 
changed to common user, the QTGUI cannot be created, which I have no idea how 
to deal with it?

Thanks a lot!

>===== Original Message From Janek Kozicki <janek_listy@xxxxx> =====
>Feng, Chen said:     (by the date of Fri, 28 Jul 2006 02:50:57 -0400)
>> Hi, all:
>> Since I want to link the YADE with OpenFOAM, the first step is to compile 
>> with the newest version 'yade-all-0.10.0', however, not so successful as
>> previous versions, I got error as listed below after typing 'make
>> compile_install':
>Have you succesfully compiled previous version?
>> 09: error: no matching function for call to _findType(int&, bool&,
>> std::basic_string<char, std::char_traits<char>, std::allocator<char> >&)_
>> make[3]: *** [DeusExMachina.o] Error 1
>> make[3]: Leaving directory
>If yes, then make sure that you do not have any files remaining from
>older version, that the new one is mistakenly trying to use. (like
>/usr/local/include/YADE, or something like that)
>findType() function is exactly the same in 0.9, and in 0.10. There is no
>difference at all. So if you have problem with compiling only the newer
>version, it must be some mistake in the system configuration (for yade),
>that I'm unable to point to you :/
>Make sure that you delete everything that previous yade versions may
>have created. Or maybe just try to compilie_install into totallly
>different directory, like INSTALL_DIR='/YADE-0.10' PREFIX_DIR='/home/fchen'
>Tell us if you have solved this problem (and how!).
>Janek Kozicki                                                         |
>Yade-users mailing list

Yade-users mailing list