← Back to team overview

kicad-developers team mailing list archive

Re: 5.1.0-rc1


On 2/6/19 2:38 PM, Carsten Schoenert wrote:
> Am 06.02.19 um 20:00 schrieb Wayne Stambaugh:
>> Any idea the number of unique downloads?  I'm guessing not many users
>> install from experimental.
> Yes, people need to know that they want to use a version from
> experimental, so the base is rather small. But I can't say anything
> about the user base that is using the version from testing/unstable
> and/or experimental.
> Looking at the pocon chart for kicad and kiacd-libraries in detail there
> are about 900 installations of the package kicad-libraries that is only
> available since version 5.0.0. Given that there are about 3000 kicad
> installations recorded than that means that over 60% are using older
> versions.
> https://qa.debian.org/popcon.php?package=kicad
> But popcon only is a bad indicator as it's up to the user to contribute,
> we wont see data from people that don't can submit data because of
> firewalls etc.
> The popcon chart has made some bump after the packages of version 5.0
> hit the archive and are currently quite near the all time high.
> You would need also to have a look into all the downstreams of Debian,
> the biggest is of course Ubuntu. So it's difficult to say how big the
> user base on Kicad 5.x on Debian and downstreams really is.
> ...
>> I'm not sure what the issue is with glm and gcc but it has been rather
>> annoying.  Hopefully clang wont make any changes that breaks the build.
> I can build the current head with clang and also can use the output as
> usual. So far I've understand the problem it's "just" because of the C++
> standard. I've seen some more warnings (than build with gcc) while build
> was running.

I tried running a Fedora build with wxGTK3 and that seemed to go ok.  I then tried enabling KICAD_SCRIPTING_WXPYTHON_PHOENIX, but I'm not sure what library KiCad is looking for.  I get this:

ModuleNotFoundError: No module named 'wx'
CMake Error at CMakeModules/FindwxPython.cmake:52 (message):
  wxPython/Phoenix does not appear to be installed on the system

I'll try to figure it out, but if anyone has a suggestion of what the library package might be called, that would help.


Follow ups