maria-developers team mailing list archive
Mailing list archive
Re: Shared plugin library build question
On Nov 09, Michael Widenius wrote:
> >>>>> "Vladislav" == Vladislav Vaintroub <wlad@xxxxxxxxxxxxxxxx> writes:
> > I think the best option for MySQL, and for MariaDB is to rename own base64.h and function prototypes in a way that it does not conflict with system headers on any system it is meant to be run on. Relying on the include order is fragile, I also do not see how it would not solve the problem with same function name different prototypes - how can we always reliably force use our base64_encode rather than system one ?
> Yes, we should rename it to my_base64.h in MySQL 5.5
> Serg, can you do that for your next push to 5.5?
Yes, but this is just one of the problems that was mentioned in this
thread. I'll wait till the list is complete and 5.5 compiles.