← Back to team overview

ubuntu-audio-dev team mailing list archive

Re: Dropping the bluez-alsa plugin and socket API of bluez


On 12/03/2012 05:10 PM, David Henningsson wrote:
On 11/29/2012 03:50 PM, Mathieu Trudel-Lapierre wrote:
Le 2012-11-29 04:42, David Henningsson a écrit :

Excellent that we are on the same page here. Do you have time to do this
(drop patch to enable socket API and drop bluez-alsa package), and
upload into Raring any time soon?

Alright. I'll try to do this at some point today.

Thanks. I tried it today, and to my surprise the bug was still there:
Unless I specifically write "Disable=Socket" in
/etc/bluetooth/audio.conf, I still get the "Profile has no transport"
error in PulseAudio.

I've verified (with apt-cache policy) that the version I'm running is
indeed 4.101-0ubuntu7.

After some hours of debugging, I believe I found it. Would you mind fixing the below, Mathieu?

It looks like our patch http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/raring/bluez/raring/view/head:/debian/patches/enable_audio_profiles.patch

...still (to some degree?) enables the socket API:

Index: b/audio/a2dp.c
--- a/audio/a2dp.c
+++ b/audio/a2dp.c
@@ -1444,7 +1444,7 @@ int a2dp_register(DBusConnection *conn,
 	int sbc_srcs = 0, sbc_sinks = 0;
 	int mpeg12_srcs = 0, mpeg12_sinks = 0;
-	gboolean source = TRUE, sink = FALSE, socket = FALSE;
+	gboolean source = TRUE, sink = TRUE, socket = TRUE;

David Henningsson, Canonical Ltd.