← Back to team overview

ubuntu-phone team mailing list archive

Re: Twitter notifications


Here it is:

phablet@ubuntu-phablet:~$ account-console show 4
account: id 4, enabled, provider: twitter
  Global settings:
    CredentialsId: 12 (<class 'int'>)
    auth/mechanism: HMAC-SHA1 (<class 'str'>)
    auth/method: oauth2 (<class 'str'>)
auth/oauth2/HMAC-SHA1/AuthorizationEndpoint: https://api.twitter.com/oauth/authorize (<class 'str'>) auth/oauth2/HMAC-SHA1/Callback: https://wiki.ubuntu.com/ (<class 'str'>)
    auth/oauth2/HMAC-SHA1/ConsumerKey: <SNIP> (<class 'str'>)
    auth/oauth2/HMAC-SHA1/ConsumerSecret: <SNIP> (<class 'str'>)
auth/oauth2/HMAC-SHA1/RequestEndpoint: https://api.twitter.com/oauth/request_token (<class 'str'>) auth/oauth2/HMAC-SHA1/TokenEndpoint: https://api.twitter.com/oauth/access_token (<class 'str'>)
    enabled: True (<class 'bool'>)
    name: <SNIP> (<class 'str'>)
  Settings for twitter-microblog
    friends/color: #05BBFC (<class 'str'>)
    friends/send_enabled: True (<class 'bool'>)
    gwibber/color: #05BBFC (<class 'str'>)
    gwibber/send_enabled: True (<class 'bool'>)
  Settings for twitter.canonicalpartners_twitter_twitter
    enabled: False (<class 'bool'>)
  Settings for com.ubuntu.developer.webapps.webapp-twitter_webapp-twitter
    enabled: True (<class 'bool'>)

"<SNIP>" is redacted information.
Thank you for your assistance, Aberto.


On 13-03-2017 10:48, Alberto Mardegan wrote:
On 10/03/2017 15:15, Paul Tait wrote:
The Twitter web app is definitely installed. But just to be sure, I removed
my account from Accounts and then uninstalled the Canonical Twitter web app
and restarted. Then I installed the Canonical Twitter web app again and
re-added my account.

Then I ran those commands again. I received the same error message (as
Can you please try running:

   account-console show <twitter account number>

and paste the result (feel free to obscure your twitter username)?


Follow ups