← Back to team overview

kicad-developers team mailing list archive

Re: python3-wxpython4 in Fedore (Re: 5.1.0-rc1)


On 2/6/19 5:16 PM, Wayne Stambaugh wrote:
> On 2/6/19 5:12 PM, Carsten Schoenert wrote:
>> Am 06.02.19 um 22:59 schrieb Steven A. Falco:
>>> I tried running a Fedora build with wxGTK3 and that seemed to go ok.
>>> I then tried enabling KICAD_SCRIPTING_WXPYTHON_PHOENIX, but I'm not
>>> sure what library KiCad is looking for.  I get this:>
>>> ModuleNotFoundError: No module named 'wx'
>>> CMake Error at CMakeModules/FindwxPython.cmake:52 (message):
>>>    wxPython/Phoenix does not appear to be installed on the system
>>> I'll try to figure it out, but if anyone has a suggestion of what the
>>> library package might be called, that would help.
>> You probably looking for python3-wxpython4 in Fedora, in Debian the
>> package python3-wxgtk4.0 is required to get wxphoenix working in kicad
>> builds

Thanks.  I'm trying a build with python3-wxpython4 and I'll report my findings.  It has made it to the packaging step, so it might succeed.

>> https://groups.google.com/forum/#!topic/wxpython-dev/EvjTb7BjXRI
> It would be helpful if we could get wxPython4/wxPython3 on Fedora to get some additional user testing.

Indeed - that is why I started trying to build it.  It might be unsuitable for F29 - might be too radical, but it would certainly be suitable for rawhide, and of course for the nightlies.

I'm not sure about F30 - that might branch off from rawhide too soon to sneak it in, but we'll see.