← Back to team overview

maria-developers team mailing list archive

Re: Shared plugin library build question


On Wed, 2011-11-09 at 09:36 -0800, Steve Ellcey wrote:

> It looks like READLINE is the way to go.  And with this change added to
> the earlier ones I got the build to complete with no errors.  I haven't
> tried running the test suite yet, but I will do that next.  This build
> was done with GCC, I want to also try building with the HP compiler to
> see how that works.
> Steve Ellcey
> sje@xxxxxxxxxx

FYI: I ran the test suite and got 2521 passes, 493 skipped, 30 disabled,
and 41 fails.

A bunch of federated tests failed with:

111109 11:19:27 [ERROR] /wsp/sje/mariadb/bazaar/repo/install/bin/mysqld:
unknown option '--federated'
111109 11:19:27 [ERROR] Aborting

I wonder if this is related to the shared library issue?  When building
5.3.2 I used '--with-plugins=max-no-ndb' on the configure.  Is there a
CMake equivalent for this?

There seem to be some other failing tests where I have garbage in the
output, I haven't investigated these but the failures are along the
lines of this difference:

-mysql.user     authentication_string   42      NULL    NO      text    65535   65535   NULL    NULL    utf8    utf8_bin        text
+mysql.user     authentication_string   42      NULL    NO      text11)e,'Y')'Insert','Update','References')J   65535   65535   NULL    NULL    utf8    utf8_bin        text

Has anyone else seen failures like this?

Steve Ellcey

Follow ups